Problem connecting to my IEXOS-100 via USB on both Indi and ASCOM #iEXOS-100 #TECHNICAL


Mehdi Tlili
 

I just received my iEXOS 100 today and wanted to test its capabilities.
Connecting to the wifi through the ExploreStars app works with no problems and I can move both axes.
The problems started when I tried to connect to the mount via usb. I first started using Indi since I use Ubuntu as main OS.
I followed the tutorial but it always ended up with a timeout when trying to connect.

Then I switched to Windows and installes ASCOM and the ASCOM 64/32 bit drivers.
I also upgraded the firmware to the latest version, this worked via usb.

When I open ASCOM diagnostics and try to connect, I also get a timeout, but the log is more detailed than in Indi

Create              Creating device
Connected           Connecting to device
Error               System.Runtime.InteropServices.COMException (0x80040402): Timed out waiting for received data
   at ASCOM.Utilities.Serial.ReceiveTerminated(String Terminator) in C:\ASCOM Build\Export\ASCOM.Utilities\ASCOM.Utilities\Serial.vb:line 1204
   at ASCOM.ES_PMC8.Telescope.CommandString(String Command, Boolean Raw)
   at ASCOM.ES_PMC8.Telescope.GetRAMotorPosition()
   at ASCOM.ES_PMC8.Telescope.set_Connected(Boolean value)
   at CallSite.Target(Closure , CallSite , Object , Boolean )
   at System.Dynamic.UpdateDelegates.UpdateAndExecute2[T0,T1,TRet](CallSite site, T0 arg0, T1 arg1)
   at ASCOM.DriverConnect.ConnectForm.btnConnect_Click(Object sender, EventArgs e) in C:\ASCOM Build\Export\ASCOM.DriverConnect\ConnectForm.cs:line 268
Dispose             Disposing of device
Dispose             Completed disposal
ReleaseComObject    Releasing COM instance
GC Collect          Starting garbage collection
GC Collect          Completed garbage collection

I need the cable connection as I plan to use a Raspberry Pi as control device for my setup.
Any help would be appreciated.

Join MAIN@ESPMC-Eight.groups.io to automatically receive all group messages.