Date   
#iEXOS-100 in Stellarium always complaining about the mount being parked #iEXOS-100 By deonb · #8053 ·
Re: Slew Errors #EXOS2 #ExploreStars By Bob Trepiccione · #8052 ·
Using the Exos-2 PMC Eight with Mac. By Mick Whitaker · #8051 ·
iEXOS-100 slow slew rate in SharpCap By deonb · #8050 · Edited
Re: EXOS2 PMC-Eight Polar Alignment issue. By Doug Doonan · #8049 ·
Re: Slew Errors #EXOS2 #ExploreStars By Bob · #8048 ·
Re: Slew Errors #EXOS2 #ExploreStars By Bob · #8047 · Edited
locked Re: ES EXOS2 and ZWO ASI Air Pro By Mario · #8046 ·
locked Re: ES EXOS2 and ZWO ASI Air Pro By Wade Prunty · #8045 ·
locked Re: ES EXOS2 and ZWO ASI Air Pro By Henry Staub · #8044 ·
Re: EXOS2 PMC-Eight Polar Alignment issue. By Mick Whitaker · #8043 ·
Re: EXOS2 PMC-Eight Polar Alignment issue. By Doug Doonan · #8042 ·
Re: Astrophotography Done with the iEXOS-100, EXOS 2, and G11 Post your Pictures and Details! Lets Show What These Mounts Can Do. #G11 #astrophotography #iEXOS-100 #EXOS2 By Wade Prunty · #8041 ·
Re: Slew Errors #EXOS2 #ExploreStars By Rick Hughes · #8040 ·
Re: EXOS2 PMC-Eight Polar Alignment issue. By Mick Whitaker · #8039 ·
Re: EXOS2 PMC-Eight Polar Alignment issue. By Bill Kinnair <kinnawill@...> · #8038 ·
Re: Slew Errors #EXOS2 #ExploreStars By Lloyd Simons <simonsl23@...> · #8037 ·
#EXOS2 #pmc-eight Unable to get my new mount to work #EXOS2 #pmc-eight By Joe Rigby · #8036 ·
Re: Slew Errors #EXOS2 #ExploreStars By Tyler Bowman - Explore Scientific Customer Service · #8035 ·
Re: EXOS2 PMC-Eight Polar Alignment issue. By Mick Whitaker · #8034 ·
3101 - 3120 of 11040