Date   
Re: EXOS2 PMC-Eight Polar Alignment issue. By Mick Whitaker · #8065 ·
Re: EXOS2 PMC-Eight Polar Alignment issue. By Bill Kinnair <kinnawill@...> · #8064 ·
Re: EXOS2 PMC-Eight Polar Alignment issue. By Bill Kinnair <kinnawill@...> · #8063 ·
Re: #EXOS2 #pmc-eight Unable to get my new mount to work #EXOS2 #pmc-eight By Tim Huseby · #8062 · Edited
Re: #iEXOS-100 in Stellarium always complaining about the mount being parked #iEXOS-100 By Wes Mcdonald · #8061 ·
Re: #iEXOS-100 in Stellarium always complaining about the mount being parked #iEXOS-100 By Wes Mcdonald · #8060 ·
Re: #iEXOS-100 in Stellarium always complaining about the mount being parked #iEXOS-100 By Wade Prunty · #8059 ·
Re: #iEXOS-100 in Stellarium always complaining about the mount being parked #iEXOS-100 By deonb · #8058 ·
Re: iEXOS-100 slow slew rate in SharpCap By deonb · #8057 ·
Re: iEXOS-100 slow slew rate in SharpCap By Wade Prunty · #8056 ·
Re: iEXOS-100 slow slew rate in SharpCap By Lloyd Simons · #8055 ·
Re: #iEXOS-100 in Stellarium always complaining about the mount being parked #iEXOS-100 By Bob Trepiccione · #8054 ·
#iEXOS-100 in Stellarium always complaining about the mount being parked #iEXOS-100 By deonb · #8053 ·
Re: Slew Errors #EXOS2 #ExploreStars By Bob Trepiccione · #8052 ·
Using the Exos-2 PMC Eight with Mac. By Mick Whitaker · #8051 ·
iEXOS-100 slow slew rate in SharpCap By deonb · #8050 · Edited
Re: EXOS2 PMC-Eight Polar Alignment issue. By Doug Doonan · #8049 ·
Re: Slew Errors #EXOS2 #ExploreStars By Bob · #8048 ·
Re: Slew Errors #EXOS2 #ExploreStars By Bob · #8047 · Edited
locked Re: ES EXOS2 and ZWO ASI Air Pro By Mario · #8046 ·
2021 - 2040 of 9972