Date   
#iEXOS-100 in Stellarium always complaining about the mount being parked By Wes Mcdonald · #9323 ·
Pushing the limits! By Wes Mcdonald · #9321 ·
Wireless connection to Stellarium to the PMC8 By Wes Mcdonald · #9319 ·
GOTO not slewing to the right place when using APT By Wes Mcdonald · #9313 ·
Meridian Flip By Wes Mcdonald · #9305 ·
Meridian Flip By Wes Mcdonald · #9301 ·
Exos II Mount cannot connect after running pmc8.exe By Wes Mcdonald · #9284 ·
Exos 2 vs eq6r-pro By Wes Mcdonald · #9277 ·
Astrophotography Done with the iEXOS-100, EXOS 2, and G11 Post your Pictures and Details! Lets Show What These Mounts Can Do. By Wes Mcdonald · #9265 ·
How to get Iexos 100 to work with Stellarium By Wes Mcdonald · #9261 ·
Another newbie question on alignment By Wes Mcdonald · #9255 ·
Astrophotography Done with the iEXOS-100, EXOS 2, and G11 Post your Pictures and Details! Lets Show What These Mounts Can Do. By Wes Mcdonald · #9252 ·
Another newbie question on alignment By Wes Mcdonald · #9246 ·
Occasional erratic behaviour when slewing EXOS2 By Wes Mcdonald · #9235 ·
Astrophotography Done with the iEXOS-100, EXOS 2, and G11 Post your Pictures and Details! Lets Show What These Mounts Can Do. By Wes Mcdonald · #9233 ·
Occasional erratic behaviour when slewing EXOS2 By Wes Mcdonald · #9232 ·
Slew Speed while using Stellarium (Serial) By Wes Mcdonald · #9227 ·
Slew Speed while using Stellarium (Serial) By Wes Mcdonald · #9220 ·
Astrophotography Done with the iEXOS-100, EXOS 2, and G11 Post your Pictures and Details! Lets Show What These Mounts Can Do. By Wes Mcdonald · #9211 ·
iEXOS-100 RA axis motor struggles, doesn't track By Wes Mcdonald · #9209 ·
261 - 280 of 1149