Date   
DEC axis not moving in certain position. Belt slipping. By Wes Mcdonald · #9555 ·
DEC axis not moving in certain position. Belt slipping. By Wes Mcdonald · #9553 ·
BETA TEST INPUTS ARE NEEDED By Wes Mcdonald · #9550 ·
DEC axis not moving in certain position. Belt slipping. By Wes Mcdonald · #9546 ·
Installed ascom drivers, explorestars dont work anymore By Wes Mcdonald · #9502 ·
ANNOUNCEMENT: New BETA Test Subgroup Available By Wes Mcdonald · #9439 ·
locked Connecting EXOS 2 PMC 8 to ASIair Pro By Wes Mcdonald · #9400 ·
locked Connecting EXOS 2 PMC 8 to ASIair Pro By Wes Mcdonald · #9398 ·
Astrophotography Done with the iEXOS-100, EXOS 2, and G11 Post your Pictures and Details! Lets Show What These Mounts Can Do. By Wes Mcdonald · #9393 ·
Astrophotography Done with the iEXOS-100, EXOS 2, and G11 Post your Pictures and Details! Lets Show What These Mounts Can Do. By Wes Mcdonald · #9380 ·
COM ERROR 303 while Firmware Update By Wes Mcdonald · #9370 ·
COM ERROR 303 while Firmware Update By Wes Mcdonald · #9368 ·
COM ERROR 303 while Firmware Update By Wes Mcdonald · #9365 ·
COM ERROR 303 while Firmware Update By Wes Mcdonald · #9364 ·
locked ASIAIR PRO with PMC8-G11 review / first light...or night that is... By Wes Mcdonald · #9363 ·
Astrophotography Done with the iEXOS-100, EXOS 2, and G11 Post your Pictures and Details! Lets Show What These Mounts Can Do. By Wes Mcdonald · #9353 ·
#iEXOS-100 in Stellarium always complaining about the mount being parked By Wes Mcdonald · #9343 ·
EXOS2 working few seconds PMC-8 not responding By Wes Mcdonald · #9333 ·
#iEXOS-100 in Stellarium always complaining about the mount being parked By Wes Mcdonald · #9323 ·
Pushing the limits! By Wes Mcdonald · #9321 ·
281 - 300 of 1187