#EXOS2

Relevance · Date   
sticky Astrophotography Done with the iEXOS-100, EXOS 2, and G11 Post your Pictures and Details! Lets Show What These Mounts Can Do. 659 messages By Frank Rich ·
Connecting EXOS 2 PMC 8 to ASIair Pro 5 messages By Steve Siedentop ·
3-4" RA wiggling while PHD2 guiding with EXOS2-GT PMC-eight 15 messages By Jennifer Shelly · Edited
Occasional erratic behaviour when slewing EXOS2 5 messages By Wes Mcdonald ·
Slew Speed while using Stellarium (Serial) 4 messages By Wes Mcdonald ·
#EXOS2 My RA on my mount is wiggling, Causing Star Trailing!!! 14 messages By nickerson.joseph@... ·
Connection Issue 9 messages By Al Parise ·
Issue with exos pcm100 By jamescasey00@... ·
Wobbeling - can i do something about it? 6 messages By borderbridge ·
PMC-Eight unit problem 86 messages By Wes Mcdonald ·
Sould I worried about this? 9 messages By Tyler Bowman - Explore Scientific Customer Service ·
Polar scope illuminator not working 4 messages By Paul Meesters · Edited
PCM Eight connection still fails over WiFi 5 messages By Paul Meesters ·
PHD2 stopped talking to my mount 39 messages By James ·
Non-Messier objects in ExploreStars 61 messages By Jerry Hubbell - Explore Scientific VP Engineering ·
Dec axis motor system faulty or newbie error?? 11 messages By Robert Hoskin ·
#astrophotography #iEXOS-100 #EXOS2 3 messages By Jeff Snell ·
Explore Stars hung up on "Please Wait" By ... ·
Problem Conected PMC-Eight 5 messages By Angelo ·
New EXOS2 owner - DEC axis Slew issue 4 messages By Paul Mogg ·
1 - 20 of 121