Topics

Accessing WiFly


W. Christopher Moses
 

Cool, thanks.

I'll try it out tomorrow.




hubbell_jerry@...
 

Here are the instructions to change the interface and enter command mode for the RN-131 module

 

First you will need the following 2 terminal programs:

 

1. Putty Serial Terminal program:  https://www.chiark.g...sgtatham/putty/
2. Parallax Serial Terminal program: https://www.parallax...serial-terminal

 

Install both of these programs by following the installation instructions

 

If you want to change the PMC-Eight WiFi RN-131 configuration then perform the following procedure:

 

CAUTION: You change these parameters at your own risk, If you want to go back to the Explore Scientific default settings you will need to perform a factory reset by issuing the command
"factory RESET" at the <4.xx> prompt. After a factory reset, you will need to run the Explore Scientific configuration commands.  Step 6 below will provide the default parameters as set by
Explore Scientific. Ensure that logging is enabled on the Putty terminal program to record these default parameters so that you can set them back to the Explore Scientific defaults if needed.

 

1.  Set your SSID to the PMC-Eight-xx, whatever yours is
2.  Using Putty, TELNET into address 192.168.47.1 port 54372.
3.  You should be greeted with the *HELLO* prompt of the RN-131 module
4.  Enter "$$$" and you should see "CMD".
5.  Hit Enter again, and the version number prompt, i.e., "<4.41>" will be displayed.
6.  Enter "get everything" and see that you get a list of all the parameters and what they are set to.

 

You can now enter configuration commands for the RN-131 module.

 

NOTE: If you change the default IP Address and Port number, then you need to use the new IP Address and Port number when connecting to the PMC-Eight with Putty.

 

If you want to change the interface from the default WiFi Port (interface 1) to the Serial Port (interface 0), do the following:

 

NOTE: This assumes that you start with the delivered configuration of the PMC-Eight with the WiFi interface enabled

 

1.  Set your SSID to the PMC-Eight-xx, whatever yours is
2.  Using Putty, TELNET into address 192.168.47.1 port 54372.
3.  You should be greeted with the *HELLO* prompt of the RN-131 module
4.  Enter "###" you should see "Diagnostic Mode Disabled#!
5.  Enter "ESX!" and you should see "ESX0!" which says that the interface was switched to the serial port (interface 0)

 

If you want to change the interface from the Serial Port (interface 0) to the WiFi Port (interface 1) then do the following:

 

1. Using the Parallax Serial Terminal, connect to the assigned serial port with connection parameters: 115200, N, 8, 1
2. Once connected, you should see the startup information scroll on the screen.
3. At the top line, enter "###" you should see "Diagnostic Mode Disabled#"
4. Enter "ESX!" and you should see "ESX1!" which says that the interface was switched to the WiFi port (interface 1)

 


W. Christopher Moses
 

Once again, thanks.


hubbell_jerry@...
 

Hi Chris,

The default configuration of the PMC-Eight is to communicate through the WiFi connection. You have to issue the command ESX! over the WiFi connection to change the communications port to the serial interface. I include a utility called the ES ASCOM Driver Tester in the SDK that exercises the ASCOM driver. In it you can send ES commands in the bottom section of the program. You need to run that program and issue the ESX! command to toggle the communications channel. I plan on writing an application note about this soon.


W. Christopher Moses
 

I'm trying to access the WiFly module in order to configure the automatic access point association. Two questions regarding that:


1. Can I just plug into the back of the pmc-8 and start issuing commands to the WiFly, or do I need to "access" it in some fashion?


I tried just plugging into it and sending commands, such as  "$$$" to enter command mode, but I never receive anything back.


2. If I should be able to, shouldn't the sequence to associate with a network be:

$$$

set wlan ssid <name>

set wlan pass <password>

set wlan join 1

save

reboot


Thanks,

Chris