ASCOM driver problem, and the fix


Yesterday I ran into the problem, living in Denmark

Where and how exactly do I change these settings, so I'll be able to use the ASCOM telescope driver?

My site location is
54°56'29.3"N 12°13'50.0"E
54.941482, 12.230558

Elevation 6 meter

Post with error messages here:

Wishing you al a great weekend
Best regards from Denmark

*Mounts:* ES EXOS2-GT PMC-8
*Scopes:* ES PN208 Photo Newton Hexafoc 8" - 812mm f/3.9
*Cameras:* Canon 5D III

Misc : Orion Mini 50mm Guide Scope with StarShoot AutoGuider camera, ES HR Koma Correktor, OHYCCD Polemaster, TS-Optics Bahtinov, BM Hexafoc 10:1

Software : APT, PHD2, Polemaster, ASPS, Stellarium, TeamViewer, DSS, PS, LR, Refurb

*PC:* Dell Latitude E6330 i5-3320M, 2.6 GHz, 16 GB - 240 SSD


Welcome to the forum and thanks Tamas for your very helpful post. It's obvious that I did not do any international testing and also that the ASCOM telescope driver template code does not consider that also since your fix was not part of the template (as far as I recall).  I will make sure your changes are included in the next release version of the code. Your identification of this problem along with a detailed solution is why we share our code and make it available to everyone who uses our system.

Thanks again!

Jerry Hubbell
Director Electrical Engineering
Explore Scientific, LLC.


Hi Jerry and everyone!

I've bought an EXOS-2 PMC-eight, and it just arrived. Great mount, I hope i can try it under the sky soon. :)
Now i'm trying to set up my gear.
Because I'm planning to use this mount mostly with ASCOM driver, i've tried the provided one and i've found a problem. I'm a developer architect (and working with .NET since 2003) so i've started to find out what happened. :)
When the ASCOM driver properties dialog opens first time, it creates the ascom profile with default values.
And there is a little problem.
I'm living in Hungary, our decimal separator is "," not "." as in the US or UK, so a FormatException occurs.
I've fixed the default profile settings from number to number, and now the driver works.
Then I've installed the driver with the source codes, to try to fix this problem at source level.
Here's the fixed parts, in Driver.vb:
    Friend Shared ApertureDiameterDefault As String = Convert.ToString(0.102)
    Friend Shared ApertureAreaDefault As String = Convert.ToString(0.00817)
    Friend Shared FocalLengthDefault As String = Convert.ToString(0.7)
    Friend Shared SiteElevationDefault As String = Convert.ToString(403.0)
    Friend Shared SiteLatitudeDefault As String = Convert.ToString(36.18063)
    Friend Shared SiteLongitudeDefault As String = Convert.ToString(-94.18838)
    Friend Shared RateOffsetDefalut As String = Convert.ToString(0.023)
    Friend Shared SiteAmbientTemperatureDefault As String = Convert.ToString(59.0)
    Friend Shared RA_SiderealRateFractionDefault As String = Convert.ToString(0.4)
    Friend Shared DEC_SiderealRateFractionDefault As String = Convert.ToString(0.4)
(these default values are declared as strings in the original source, and Convert.ToString() uses the current culture setting, so it'll work with every decimal separator setting)

Jerry, i think this small change in the driver could be useful for some users with non-US/UK localization setting. What do you think?

Best regards,
Tamas Hargitai