PMC-8 ZERO Connectivity UDP, TCP, Serial #iEXOS-100 #TECHNICAL

Naim Conrad Vilabrera <naimcvilabrera94@...>

Good day or night to you all,

This is my first time using I hope that I’m posting properly.

I'm having trouble connecting my ES iEXOS-100 PMC-8 to Prism v10. I purchased this mount to keep me occupied while I save money for a Losmandy G11 PMC-8. The iEXOS has PMC-8 and wireless ASCOM capabilities. I've downloaded the ASCOM platform and drivers. My camera connects to Prism. Prism recognizes my mount (see photo 1 and 2…link is below).  

I'm wirelessly connected to the mount via my computer. I get an error message (see photo 3) when I attempt to connect the mount. When I initialize, the green "processing" light on the mount activates but deactivates soon afterward. There seems to be communication at first, then the communication between PRISM and PMC-8 drops. 

The IP address is correct, The proper WiFi module is used. ASCOM diagnostic says everything is fine with the driver. 

Link to photos.

Troubleshoot 2 - Wes McDonald's Recommendations

Wes Speaking:

I am unfamiliar with the Prism but I have an idea.



1.  Internet connectivity is not available when you are connected to the PMC8.  I can't say if that upsets Prism, you should try to find out.


2.  Since you mentioned that you are connected to the PMC8 with explorestars,  the PMC8 is set for UDP communication.  I believe the most likely problem is that the ASCOM driver requires the PMC8 to be set for TCP.  This is done by use of the Configuration Manager utility.  The utility can be found at near the bottom of the list of files.  Load it.  When you run it make sure that before you do the laptop is connected wirelessly to the PMC8.  Be sure to get the settings on the Basic tab correct for the mount type.  The comm port should not be required.  The utility should find the mount and you will see a button to set the communications to TCP.  Once this is done, closethe CM and try to set things up again.  It should work.  Note that if you should wish to run explorestars later you will have to use the configuration manager to switch the mount back to UDP mode.  If this does not work then move on to the things to try below.


3. You could try the following:  Instead of connecting Prism directly to the ES ascom driver, instead run the ASCOM telescope-dome control hub, POTH.  From setup POTH to use the ASCOM ES driver.  In PRism choose POTH as the telescope.  Before you start, make sure the PMC8 is set to TCP by using the configuration manager as detailed in #2.


4.  After setting up Prism and POTH, tell POTH to connect to the mount.  If the POTH green light comes on you are there. BUT before you try to move the mount be sure to unpark it using the POTH unpark button.  If you leave it parked an error message will be displayed. 

None of the aforemention recommendations worked. My computer can connect to the mount's WiFi. That's as far as the communication goes. 

Troubleshoot 3: 

  1. Uninstall ASCOM ES_PMC8 Telescope Driver version 1.14, PMC-8 CM 1.0.3, and PMC8 (TW Erickson)
  2. Restart computer and install the aforementioned applications. Restart computer.
  3. Connect ASI Camera to PRISM. Connection successful. Disconnect. This was a test of PRISM’s connectivity.


4.      Open ASCOM Diagnostic application. Run Diagnostic. 0 fails. 1 exception.

5.      Choose Device (64-bit). Choose ES_PMC8 Telescope. Ensure mount Is iEXOS 100. Enable TCP/IP is enabled. WiFi module is ESP-WROOM2. IP address is not default value, but matches PMC-8 WiFi IPv4 DNS server. UDP/TCP Port is default value. Select King tracking rate.

6.      Device Connection Tester. Connect. Get Profile. COM Port <empty>. IP Address is correct. IP Port is default value. Lat/Long is correct. Wireless Enabled = True. Wireless Protocol = TCP. Exit ASCOM Diagnostic tool.

7.      Repeat Steps 4-6 while connected to PMC-8 WiFi. Results of test do not differ. Exit ASCOM Diagnostic tool.


8.      Remain connected to PMC-8 WiFi. open PMC-8 Configuration Manager. Connections Tab: Change Mount Type to iEXOS-100. Advanced Tab: Select TCP. NOTE: “Current Mount Connection Method = Unknown. Current WiFi Network = PMC-Eight-ABE7”

9.      Find Current Connection = “The mount does not appear to be connected. Please check your settings and network connection.”

10.   Find = “Could not automatically find the com port for PMC-8.”

11.   Close PMC-8 CM.


12.   Attempt to revert to UDP. Reopen PMC-8 CM. Select UDP. Close PMC-8 CM.

13.   Open ExploreStars. ExploreStars closes automatically (crashes?) after opening.


Notes: The PMC-8 controller makes a weird hissing noise when the green light is off. If I plug in my USB to mini-USB cable, the green light turns on momentarily and the hissing noise stops. Similar to the above issues, I cannot connect via a wired connection.


When I try to connect via PRISM, a new error message arises in addition to the prior error message.

New message: “Telescope ASCOM, general error into order loop, hardware link dropped [ES_PMC8 Telescope] -> Right Ascension”

Existing message: “Error during enabling link – Error while initializing telescope control: Unable to initialize telescope”

I think that I’m having a COM PORT issue. My computer is a Dell XPS 15 from August 2018. 
Troubleshoot 4

I followed application note 3 (

Packet Sender does not show a response. The green LED does not activate.


I tried using putty, but when I open TELNET, “Network Error – Connection Refused”

How do I perform a factory reset? Should I perform a factory reset? 

I’ve been waiting half a year to go imaging for the first time. I saved for my scope, camera, and accessories. I’m still saving to purchase a G-11 PMC-8 (I bought the iEXOS 100 for the meantime), but I’m not having a good experience with PMC-8; however, the assistance of the Groups.Io community is great. Yesterday night and tonight are some of the best conditions for Andromeda and the Veil Nebula, my first two intended targets. 



On Sat, Sep 21, 2019 at 07:38 AM, Naim Conrad Vilabrera wrote:
Prism v10
One thing I noticed right away is that in Hardware Setup window, Choose Telescope Mount, you need to choose POTH, NOT ES_PMC8 Telescope. This is what I choose in Cartes du Ciel.

Naim Conrad Vilabrera <naimcvilabrera94@...>

I think my problem is deeper than that. Software for the PMC-8 like PMC-8 configuration manager doesn't communicate with PMC-8 on the mount.