Topics

ASCOM Freezing iEXOS 100 PMC-Eight


ToddB
 

I've had this issue since day 1. ASCOM constantly freezes. I have installed the latest ASCOM and have all updated drivers. I wiped my hard drive clean a few times, and I even went out and bought a brand new computer. Nothing works. Whether I'm using Carte du Ciel, or using ASCOM Device Hub directly, the issue persists.

Is this an issue inherent with ASCOM and the iEXOS 100 PMC-Eight? Are there setting I need to change?


Lloyd Simons
 

Toddb,

Are you using ASCOM 6.5? If so try uninstalling and installing 6.4 SP 1. I had issues with 6.5.
--
Lloyd Simons
Mattawan, MI
Telescopes: Astrotech AT72ED II, Orion 8" Dobsonian, Tectron 15" Dobsonian, Celestron Super Polaris C8
Imaging Camera: Canon T3i
Guide Camera: QHY5L-IIM on a 60mm F4 Guidescope
Mounts: iExos-100 PMC-8, Vixen Super Polaris
Mount Control: KODLIX gn41 mini PC, Explorestars on a Lenovo Tab 2 A10-70F Android 6.0
Software: N.I.N.A. for imaging, PHD2 for guiding, Sharpcap for PA, Cartes du Ciel, PixInsight


Wes Mcdonald
 

Todd

Be assured the issues you are having are not related to the iexos.  

Some have indeed found the new ascom version is bugged. 

With POTH in ascom 6.4 I have had occasional POTH crashes.  But these are seldom and I don’t think it has happened once I replaced my windows tablet with a PC.  Hasn’t happened with my bootcamped Mac mini.

We’d

--
Wes, Southport NC
PMC-8, ES ED 127, 10" LX200GPS, Astro-Tech 8" Newt, ETX-90
Polemaster, Orion ST-80 and SAG
Electrical Engineer, Retired


ToddB
 

Thanks for the replies. For posterity...

Initially, I was using ASCOM 6.4 and it was constantly freezing. Then I read a post where someone said to point to POTH from Carte du Ciel and other programs, and POTH to the driver. This helped a great deal, but I was still having several freezes per session. Then ASCOM 6.5 came out, so I updated to use that. The freezing persisted in about that same amount. That's when I started wiping my hard drive clean (3 different times), and eventually bought a new computer and installed ASCOM 6.5. Problem has persisted.

One thing I've noticed is that the freezing is more persistent if I am running the Celestron Desktop Focuser program. But even if I'm only running ASCOM, I get the freezing.

I've uninstalled ASCOM 6.5 and loaded 6.4. I'll try it tonight to see if it helped.

Again, thanks for the replies.

Todd


ToddB
 

Hi Lloyd. I see you're in Michigan. I'm in Clinton Twp, MI, about 45 minutes outside of Detroit...and about 20 minutes from Chuck of Chuck's Astrophotography. :)  Nice to see some local boys here.


Lloyd Simons
 

I guess I would need more information about you setup to determine what might be the problem. One possibility is if you try to connect the mount driver to more than one piece of software you will have issues. Only connect to mount to POTH and then connect your individual programs via POTH.

I love living in MI but the permacloud on the west side makes AP difficult. 😁
--
Lloyd Simons
Mattawan, MI
Telescopes: Astrotech AT72ED II, Orion 8" Dobsonian, Tectron 15" Dobsonian, Celestron Super Polaris C8
Imaging Camera: Canon T3i
Guide Camera: QHY5L-IIM on a 60mm F4 Guidescope
Mounts: iExos-100 PMC-8, Vixen Super Polaris
Mount Control: KODLIX gn41 mini PC, Explorestars on a Lenovo Tab 2 A10-70F Android 6.0
Software: N.I.N.A. for imaging, PHD2 for guiding, Sharpcap for PA, Cartes du Ciel, PixInsight


ToddB
 

Thanks, Lloyd.
I switched back to ASCOM 6.4, and its a little better, but barely.

So, here are my steps:

1. Open Carte du Ciel, and hit Connect. This starts POTH automatically. (So, I have POTH connected to the PMC8 driver, and Carte du Ciel connected to POTH.)
2. Then I open the ASI imaging software.

That's basically it.

If I need to focus, I have to disconnect the mount from POTH, otherwise the focus software immediately causes it to crash. So, I'll focus, then close that software, then connect to POTH via Carte du Ciel.

I had the thought today that if the focus software causes it to crash, maybe the imaging software also makes it unstable. If I can get out tonight, I'll try FireCapture.

I have to vent for a minute. I've been trying to fix this for months...ever since I got the mount. Even ExploreStars doesn't run all that stable. More than half the time that I try to do a star alignment, it crashes. Sometimes its in the middle of a slew when it crashes, and the slew doesn't stop in that case. I have had to start my nights over several times a night every single night. I'm pretty close to calling it quits.

I sincerely appreciate the help.


jrichard333 <jrichard333@hotmail.com>
 

Good day ToddB,

 

A couple of questions/ suggestions:

1.       Try running POTH first before starting other applications

For the most part, only one connection at a time through POTH.  I run a different setup than you.

POTH, Stellarium Scope, Stellarium, and APT.   When I have POTH connected and APT, I can go back

and forth with no issues, when Stellarium scope is active, on the third exchange, POTH crashes.

2.       Have you upgraded your mount to the latest firmware?

3.       Check and measure your battery voltage to make sure it is above 10.8 volts DC at the lowest.

4.       If using your PC, are you running these apps as an Administrator?

5.       Do you have enough RAM or hard drive space?

6.       Have you downloaded all of the updates for your computer?

 

ExploreStars App:

1.       How much free space do you have available?

2.       How many other apps are running in the background?

3.       The only issue I have with the Explorestars app is that “9” key.  Sometimes it performs an electronic stick

and I have to click it again to get it to stop slewing.

 

Electronic focuser:

1.       What software are you using and are you running it as an Administrator?

2.       Have you tried running it in compatibility mode?

 

I am thinking about deigning/ building my own electronic focuser for my Maksutov.

 

I hope this helps.

 

JR

From: MAIN@ESPMC-Eight.groups.io [mailto:MAIN@ESPMC-Eight.groups.io] On Behalf Of ToddB
Sent: Sunday, June 28, 2020 5:28 PM
To: MAIN@ESPMC-Eight.groups.io
Subject: Re: [ESPMC-Eight] ASCOM Freezing iEXOS 100 PMC-Eight

 

Thanks, Lloyd.
I switched back to ASCOM 6.4, and its a little better, but barely.

So, here are my steps:

1. Open Carte du Ciel, and hit Connect. This starts POTH automatically. (So, I have POTH connected to the PMC8 driver, and Carte du Ciel connected to POTH.)
2. Then I open the ASI imaging software.

That's basically it.

If I need to focus, I have to disconnect the mount from POTH, otherwise the focus software immediately causes it to crash. So, I'll focus, then close that software, then connect to POTH via Carte du Ciel.

I had the thought today that if the focus software causes it to crash, maybe the imaging software also makes it unstable. If I can get out tonight, I'll try FireCapture.

I have to vent for a minute. I've been trying to fix this for months...ever since I got the mount. Even ExploreStars doesn't run all that stable. More than half the time that I try to do a star alignment, it crashes. Sometimes its in the middle of a slew when it crashes, and the slew doesn't stop in that case. I have had to start my nights over several times a night every single night. I'm pretty close to calling it quits.

I sincerely appreciate the help.