Unable to connect wifi or serial to Windows 10 laptop


Dallin
 

Thank you to those who helped with my WIFI connection issue. It turns out my computer was affected by the windows 10 connection issue. I am running Windows 10 Home version 1909. OS build 18363.1379. The fix from ES in the link below resolves my WIFI connection issue. 

https://explorescientificusa.com/pages/windows-10-network-issue-with-exos-2-g11-pmc-eight

cheers,
--
Dallin McLaws
Location: 
Vail, AZ
Mounts
: ES PMC-Eight EXOSII 
Scopes: Omegon 110 F6 FPL-53 ED APO CF
Cameras:  Nikon D850
Operating System: Dell XPS Windows10 / Ipad Mini
Software: ExploreStars


LuckyDuck
 

Hi Dallin,

in case you want to connect via serial, you first have to change the connection mode on the pmc eight. Therefore you first have to successfully connect via wifi. Connect the serial cable on pmc eight and computer and check the com-port settings:

1) First you should check your com-port settings in the device manager of your computer. Make sure the Baut rate is at 115200 Bits per second or higher. I have mine set to 128000 bits per second and it works fine

2) Set your ascom driver settings to "enable wifi"
3) connect to the pmc-eight wifi
4) open the Explore Scientific Configuration manager. Like in your case the "current wifi network Pmc-eight-xx" should show up green
5) go on the "connection" tab and klick "Do it" at Find current connection mode
6) if successful the software should tell you something like "Mount appears to be connected on TCP"
7) click on "Do it" next to Via Ascom serial --> now your pmc eight is ready for a connection via serial

8) open the ascom driver settings and enable "serial connection"

9) try to connect in ascom. It should work now

If one of the steps dont work imediately, try to reboot computer and/or the pmc eight and continue. Let me know if it works. Once it is setup to serial its a very stable connection.

Lukas

--
_______________________________________________________________

Mounts
: ES PMC-8 EXOS-2
Scopes: ES AR152 refractor, Tamron zoom-lens 70-300 mm
Cameras:  Sony a6000
Msc: none
Software: Siril, Affinity Photo, Sony Remote Control


Dallin
 

Thank you to all who have been trying to help. Ultimately I would like to connect wired via serial and utilize NINA. However, I would like to learn to connect via either. Attached are my PMC8 ASCOM driver settings.

When using the CM with the serial connected I get the COM3 option. When I push "find" it says that "PMC8 is connected via com port - this does not mean you mount is connected via serial"

When I push "do it" the CM says  "the mount does not appear to be connected. Please check you settings and network connection.

Under the advanced tab with TPC selected I push ESGv and get the following error "unable to send command"

Under the advanced tab with serial selected I push ESGv and the message box says "received" but the mount connection method remains at "NONE"

attached are screenshots of each step and error/message.


--
Dallin McLaws
Location: 
Vail, AZ
Mounts
: ES PMC-Eight EXOSII 
Scopes: Omegon 110 F6 FPL-53 ED APO CF
Cameras:  Nikon D850
Operating System: Dell XPS Windows10 / Ipad Mini
Software: ExploreStars


LuckyDuck
 

Hi Dallin,

I guess Doug asked the right question: do you want to connect via wifi or serial? both at the same time is not possible. also with esrial you have to you ascom instead of the explorestars app.

My guess is, that you actually want to use the explorestars app via wifi.

To check if you are affected by the mentioned connection issue please check your current ip-settings via command line:
https://www.youtube.com/watch?v=iPkoX0rxIxY
Important are the settings of your wifi controller.

if yes, follow the steps of the following video to set a static ip-adress properly:
https://www.youtube.com/watch?v=hVdN1_YHE4A

best regards
Lukas


Andrew Houseman
 

Also, make sure everything is connected BEFORE powering up the PMC8.  If you connect the serial cable to an already powered on mount, it won't do anything.

I also find the main connection page to be cryptic and unhelpful.  Go to the advanced tab.

Under communication method, click TCP then click the "version (ESGv!)" Button. 

The mount should reply with *HELLO*ESXO!.  
Switch to Serial and click version again. It will have no response.

Now click back to TCP and the Wired/Wireless toggle.
Now Version + TCP will respond with just *HELLO* and Version + serial will respond with a long version number.

Provided you got that long version number back, you should now be good to go for serial control


On Thu, Feb 18, 2021, 8:56 PM Dallin <Vaught427@...> wrote:
Hi Doug, when I click on the com port without a serial cable attached the CM doesn't give me any options to select. It is just a blank field. Is there a way to make it say com3?

Cheers
--
Dallin McLaws
Location: 
Vail, AZ
Mounts
: ES PMC-Eight EXOSII 
Scopes: Omegon 110 F6 FPL-53 ED APO CF
Cameras:  Nikon D850
Operating System: Dell XPS Windows10 / Ipad Mini
Software: ExploreStars


Doug Doonan
 

Darin,
Are you trying to use a wifi connection?
Doug



-----Original Message-----
From: Dallin <Vaught427@...>
To: MAIN@ESPMC-Eight.groups.io
Sent: Thu, Feb 18, 2021 8:56 pm
Subject: Re: [ESPMC-Eight] Unable to connect wifi or serial to Windows 10 laptop

Hi Doug, when I click on the com port without a serial cable attached the CM doesn't give me any options to select. It is just a blank field. Is there a way to make it say com3?

Cheers
--
Dallin McLaws
Location: 
Vail, AZ
Mounts
: ES PMC-Eight EXOSII 
Scopes: Omegon 110 F6 FPL-53 ED APO CF
Cameras:  Nikon D850
Operating System: Dell XPS Windows10 / Ipad Mini
Software: ExploreStars

--

Doug Doonan
HomeBru  6 inch Reflector  f 6.6
HomeBru  85 mm Refractor  f 5.6
PMC-8, EXOS 2
Long retired EE.


Dallin
 

Hi Doug, when I click on the com port without a serial cable attached the CM doesn't give me any options to select. It is just a blank field. Is there a way to make it say com3?

Cheers
--
Dallin McLaws
Location: 
Vail, AZ
Mounts
: ES PMC-Eight EXOSII 
Scopes: Omegon 110 F6 FPL-53 ED APO CF
Cameras:  Nikon D850
Operating System: Dell XPS Windows10 / Ipad Mini
Software: ExploreStars


Doug Doonan
 

Hi Dalin,
On my setup I usually have the COM port set to COM3. That might help in this case.
Doug



-----Original Message-----
From: Dallin <Vaught427@...>
To: MAIN@ESPMC-Eight.groups.io
Sent: Thu, Feb 18, 2021 8:37 pm
Subject: Re: [ESPMC-Eight] Unable to connect wifi or serial to Windows 10 laptop

Unfortunately I am still having the connection issue after updating the PMC8 wifi settings.  Attached are the settings I change to and the message the CM is giving me. Any other suggestions would be much appreciated.

cheers,
--
Dallin McLaws
Location: 
Vail, AZ
Mounts
: ES PMC-Eight EXOSII 
Scopes: Omegon 110 F6 FPL-53 ED APO CF
Cameras:  Nikon D850
Operating System: Dell XPS Windows10 / Ipad Mini
Software: ExploreStars

--

Doug Doonan
HomeBru  6 inch Reflector  f 6.6
HomeBru  85 mm Refractor  f 5.6
PMC-8, EXOS 2
Long retired EE.


Dallin
 

Unfortunately I am still having the connection issue after updating the PMC8 wifi settings.  Attached are the settings I change to and the message the CM is giving me. Any other suggestions would be much appreciated.

cheers,
--
Dallin McLaws
Location: 
Vail, AZ
Mounts
: ES PMC-Eight EXOSII 
Scopes: Omegon 110 F6 FPL-53 ED APO CF
Cameras:  Nikon D850
Operating System: Dell XPS Windows10 / Ipad Mini
Software: ExploreStars


Andrew Houseman
 

Nope. This procedure will change only the PMC8 wifi connection.


On Thu, Feb 18, 2021, 2:56 PM Dallin <Vaught427@...> wrote:
Andrew, Thank you for the reply! I will try that fix tonight. Will I need to change settings back after connecting to the mount in order to use my home wifi again? 

Thanks again for the help.
--
Dallin McLaws
Location: 
Vail, AZ
Mounts
: ES PMC-Eight EXOSII 
Scopes: Omegon 110 F6 FPL-53 ED APO CF
Cameras:  Nikon D850
Operating System: Dell XPS Windows10 / Ipad Mini
Software: ExploreStars


Dallin
 

Andrew, Thank you for the reply! I will try that fix tonight. Will I need to change settings back after connecting to the mount in order to use my home wifi again? 

Thanks again for the help.
--
Dallin McLaws
Location: 
Vail, AZ
Mounts
: ES PMC-Eight EXOSII 
Scopes: Omegon 110 F6 FPL-53 ED APO CF
Cameras:  Nikon D850
Operating System: Dell XPS Windows10 / Ipad Mini
Software: ExploreStars


Andrew Houseman
 

there is a bug in Win 10 causing an incompatibility with out of the box settings.

before connecting to the mount
Right click on the wifi icon from the tray->open network & internet settings
select Wi-Fi then Manage Known Networks
select the PMC8 network
under IP settings, click edit
change to Manual
IPv4 On
IP address 192.167.47.11
Subnet Prefex Length 24
Gateway 192.168.47.1
Preferred DNS 192.168.47.1
Alternate DNS 192.168.1.1
IPv7 Off
Save


On Thu, Feb 18, 2021 at 2:39 PM Dallin <Vaught427@...> wrote:
Hi,

I have been using/learning the ES EXOS2 PMC-8 with my Ipad Mini since June for visual use. My setup is working great with the IPAD Mini However, I just purchased a new Dell XPS 9300 with Windows 10 home edition to operate the EXOS2 PMC-8 for astrophotography. I am unable to connect my laptop to the mount via WIFI or USB FTDI chipset Serial cable. I have downloaded the CM, disabled my firewall, and enabled the port. 64 bit PMC8 drivers are installed and FTDI chipset drivers are installed. I cannot connect via Configuration Manager. The CM shows that I am connected to the PMC8 WIFI network but connection shows "unknown' or "none" and will not communicate with the mount when I check for connection or press "do it."  I have the EXOS2 mount is selected in the CM.  When I try to connect via wired connection, it brings up com3 port but again will not connect to the mount when I select "do it" Any thoughts?


--
Dallin McLaws
Location: 
Vail, AZ
Mounts
: ES PMC-Eight EXOSII 
Scopes: Omegon 110 F6 FPL-53 ED APO CF
Cameras:  Nikon D850
Operating System: Dell XPS Windows10 / Ipad Mini
Software: ExploreStars


Dallin
 

Hi,

I have been using/learning the ES EXOS2 PMC-8 with my Ipad Mini since June for visual use. My setup is working great with the IPAD Mini However, I just purchased a new Dell XPS 9300 with Windows 10 home edition to operate the EXOS2 PMC-8 for astrophotography. I am unable to connect my laptop to the mount via WIFI or USB FTDI chipset Serial cable. I have downloaded the CM, disabled my firewall, and enabled the port. 64 bit PMC8 drivers are installed and FTDI chipset drivers are installed. I cannot connect via Configuration Manager. The CM shows that I am connected to the PMC8 WIFI network but connection shows "unknown' or "none" and will not communicate with the mount when I check for connection or press "do it."  I have the EXOS2 mount is selected in the CM.  When I try to connect via wired connection, it brings up com3 port but again will not connect to the mount when I select "do it" Any thoughts?


--
Dallin McLaws
Location: 
Vail, AZ
Mounts
: ES PMC-Eight EXOSII 
Scopes: Omegon 110 F6 FPL-53 ED APO CF
Cameras:  Nikon D850
Operating System: Dell XPS Windows10 / Ipad Mini
Software: ExploreStars