iexos-100 ASCOM Errorr 40040407 - GetRAMotorPosition #iEXOS-100


Phil Knowles
 

Apologies if this is something that has already been covered, but I've spent the last hour and while I have found a few 'similar issues' on the group/google I have not found a solution.

I Upgraded my PMC-8 to 20A01.1 yesterday - the easier wifi channel swap and Dual Wifi/serial was a big sell for me.

As it happens I started the install process from fresh windows 10 laptop

Having gone through the process I ultimately have ended up not being able to connect to the PMC-8 via in ASCOM

I've setup the properties:



But When I test the connection in Ascom diagnostics I get an Error  Ascom.notconnectedException: Get RAMotorPosition.

If I swap to "enable serial port" in the properties and use one of those wirey things, it's all good and I can even use POTH to connect and control....so wires work!
I do not have any issues using explore stars via wifi on my tablet either.

If I go into the PMC8 Configuration manager utility, I can select TCP connection and test the "GET RA Position" successfully.

I verified IP address gateway with IPconfig so I don't think there is an issue there.
I have disabled both my bitdefender firewall and the windows firewall. To rule them out.

Have I forgot to do something in ascom? I have 6.5 SP1. 

One thing that slightly worried me was in the new firmware configuration tool, I selected the mount type as "iEXOS100"

But when I did " Get current configuration" the message view shows:

Mount Type Error!:Please Select G11 or EXOS2 Mount,

             and Press SET New Configuration

And the Wifi Type is shown as RN131 at the top (was expecting to perhaps see the ESP device instead like in the Splash ???)

I was reluctant to change the Mount type given iEXOS100 is in the mount type list - why else would it be there....

Any pointers would be appreciated.

It's bed time for me now (UK), so please don't think I'm ignoring any responses.

 

Cheers

 

Phil

 

 

 


Wes Mcdonald
 

Phil

Oh. Interesting

In will give this a go tomorrow and see what I find.  

I think you are making an error in the way you set the mount but I don’t think that is messing you up.  After booting the pmc8 boot the UFCT.  Set the comm port and press get configuration.  The. Change the mount to iexos, and press say configuration.   This will reboot the pmc8 with iexos set as the mount type.  If you press the reboot and show splash screen you should then see in one of the last few lines the detected WiFi to be the esp32.

I will let you know what I find out about WiFi ascom in your afternoon.

Wes



--
Wes, Southport NC
EXos2-GT PMC-8, iExos 100, ESG11
ES ED 127+MoonLite Focuser, 10" LX200GPS+ MoonLite focuser+wedge, Astro-Tech 8" Newt, ETX-90, 60mm no-name guide scope ~ 260mm FL
Polemaster, Orion ST-80 and SAG, ZWO 290MM, D5300 astro modified, ASI071 cooled OSC, ASI MM290 guide camera
Nina, Bootcamped Mac Mini control computer, RDP to iMAC
110 amp hour lead acid deep discharge battery for field power
Electrical Engineer, Retired


Wes Mcdonald
 

Phil

Having some issues with this myself.  Looking into it tomorrow.  Late here.

Wes


--
Wes, Southport NC
EXos2-GT PMC-8, iExos 100, ESG11
ES ED 127+MoonLite Focuser, 10" LX200GPS+ MoonLite focuser+wedge, Astro-Tech 8" Newt, ETX-90, 60mm no-name guide scope ~ 260mm FL
Polemaster, Orion ST-80 and SAG, ZWO 290MM, D5300 astro modified, ASI071 cooled OSC, ASI MM290 guide camera
Nina, Bootcamped Mac Mini control computer, RDP to iMAC
110 amp hour lead acid deep discharge battery for field power
Electrical Engineer, Retired


Phil Knowles
 

Thanks Wes, I will try setting the mount configuration when I get home later today.
Even if not the main issue....it feels better if it set right.

On Mon, 18 Oct 2021, 04:52 Wes Mcdonald, <wesmcd6@...> wrote:
Phil

Having some issues with this myself.  Looking into it tomorrow.  Late here.

Wes


--
Wes, Southport NC
EXos2-GT PMC-8, iExos 100, ESG11
ES ED 127+MoonLite Focuser, 10" LX200GPS+ MoonLite focuser+wedge, Astro-Tech 8" Newt, ETX-90, 60mm no-name guide scope ~ 260mm FL
Polemaster, Orion ST-80 and SAG, ZWO 290MM, D5300 astro modified, ASI071 cooled OSC, ASI MM290 guide camera
Nina, Bootcamped Mac Mini control computer, RDP to iMAC
110 amp hour lead acid deep discharge battery for field power
Electrical Engineer, Retired


Jennifer Shelly
 

Phil:

First you need to select the “Enable Serial Port” radio button in the ASCOM driver and the select your COM port. Currently you have “Enable WiFi TCP/IP” selected which is default.  Then you would open UFCT and follow Wes’ instructions.
--
Sincerely,

Jennifer Shelly
AstroPorch, VA

Mounts: ES PMC-8 G-11, ES PMC-8 EXOS-2, ES PMC-8 iEXOS-100
Scopes: ES ED127 FCD-100, Askar FRA400, Askar FRA600, ES N208CF, QHY Mini Guide Scope, Solomark F60 Guide Scope
Cameras: QHY600M, QHY128C, QHY168C, QHY183M
Misc: MoonLite CFL 2.5 / High Res Stepper / V2 Mini Controller, Baader SteelTrack NT / SteelDrive II, Baader UFC, Optolong 2" L-Pro / L-eNhance / L-Extreme, QHY CFW3-L, Baader 2” LRGBSHO CCD, Primaluce Lab Sesto Senso 2, QHY CFW3-S, Optolong 1.25” LRGBSHO CCD
Imaging Software:  NINA, APT, SharpCap Pro
Processing Software: PixInsight, Lightroom, Premiere Elements


Phil Knowles
 

So I deleted the last message I put not to hide my shame, rather to ensure i didn't further waste anyone else's time or hide this after a lengthy post of UFCT session log.

the very first word of my original post sums this up...

What it is very important to do is know what kind of mount you have....my dad has an iexos-100....I on other hand am an idiot with an EXOS II.

if I set the configuration up correctly....it works....but it doesn't make me feel any better :(

So thanks because if i was left with no advice/feedback at all I'd probably still be trying to poke that square peg in a round hole.

 

I'm sad now...

 

 


Wes Mcdonald
 

Phil:

This is important, please tell me -- you have an Exos2, correct?  That would explain things if you repeatedly tried to tell it you were an iexos.  No worries, that's a good thing you discovered and rectified.

MEanwhile, since you were getting errors and it looked to me you were trying to use wifi, i also tried wifi and i believe there is an issue with wifi ascom on the iexos 100,.  Not sure yet but pretty sure.  So, your effort has likely paid dividends, even if they were unintended by you!  Thanks for participating on the forum.

Wes.


Virus-free. www.avg.com

--
Wes, Southport NC
EXos2-GT PMC-8, iExos 100, ESG11
ES ED 127+MoonLite Focuser, 10" LX200GPS+ MoonLite focuser+wedge, Astro-Tech 8" Newt, ETX-90, 60mm no-name guide scope ~ 260mm FL
Polemaster, Orion ST-80 and SAG, ZWO 290MM, D5300 astro modified, ASI071 cooled OSC, ASI MM290 guide camera
Nina, Bootcamped Mac Mini control computer, RDP to iMAC
110 amp hour lead acid deep discharge battery for field power
Electrical Engineer, Retired


Phil Knowles
 

Yes I have an Exos2.
Wifi operation is now working ok

I've occasionally had the knack of stumbling across real problems by creating  my own problems. so if something good has come of it.


On Mon, 18 Oct 2021 at 20:12, Wes Mcdonald <wesmcd6@...> wrote:
Phil:

This is important, please tell me -- you have an Exos2, correct?  That would explain things if you repeatedly tried to tell it you were an iexos.  No worries, that's a good thing you discovered and rectified.

MEanwhile, since you were getting errors and it looked to me you were trying to use wifi, i also tried wifi and i believe there is an issue with wifi ascom on the iexos 100,.  Not sure yet but pretty sure.  So, your effort has likely paid dividends, even if they were unintended by you!  Thanks for participating on the forum.

Wes.


Virus-free. www.avg.com

--
Wes, Southport NC
EXos2-GT PMC-8, iExos 100, ESG11
ES ED 127+MoonLite Focuser, 10" LX200GPS+ MoonLite focuser+wedge, Astro-Tech 8" Newt, ETX-90, 60mm no-name guide scope ~ 260mm FL
Polemaster, Orion ST-80 and SAG, ZWO 290MM, D5300 astro modified, ASI071 cooled OSC, ASI MM290 guide camera
Nina, Bootcamped Mac Mini control computer, RDP to iMAC
110 amp hour lead acid deep discharge battery for field power
Electrical Engineer, Retired