Topics

Driver Update


CYRIL BONNETT
 

Hi Jerry

I receive this when trying to set Cartes du Ciel up


,Ascom Telescope Chooser


Incompatible driver

This 32bit only driver won't work in a 64bit application even though it is correctly registered as a 32bit driver.

Please contact driver author and request updated driver.

 

Are you there any plans to update the driver?


Cyril


hubbell_jerry@...
 

Hi Cyril,

I compiled the PMC-Eight ASCOM driver as a 32-bit driver to maintain compatibility with older software systems, Some 64 bit programs work fine with it (MaximDL for example), but others do not, such as Cartes du Ciel. There are two solutions, the first one is to compile the driver as a 64-bit driver and release it as a choice. I assume this will work with the 64-bit Cartes du Ciel, but have not tested that. That may not happen for a few weeks, if there is a big need for it.

The solution that I know works is to just install the 32-bit version of Cartes du Ciel. I have tested that and others have tested that, and it seems to work fine with the driver. 

To be clear, the issue only arises when you are connecting the 64-bit version of Cartes du Ciel directly to the PMC-Eight driver. If you are going to use more than one ASCOM client at the same time, such as Cartes du Ciel, and PHD2, then you would need to use a driver hub, or server such as POTH which I recommend and comes with the ASCOM platform.  This is the easiest solution and gives you options going forward.

Jerry Hubbell
Director Electrical Engineering
Explore Scientific, LLC.


CYRIL BONNETT
 

Hi Jerry

Thanks for that

Cyril

 

From: ESPMC-Eight@...
Sent: 22 March 2018 15:12
To: ESPMC-Eight@...
Subject: [ESPMC-Eight] Re: Driver Update

 

 

Hi Cyril,

 

I compiled the PMC-Eight ASCOM driver as a 32-bit driver to maintain compatibility with older software systems, Some 64 bit programs work fine with it (MaximDL for example), but others do not, such as Cartes du Ciel. There are two solutions, the first one is to compile the driver as a 64-bit driver and release it as a choice. I assume this will work with the 64-bit Cartes du Ciel, but have not tested that. That may not happen for a few weeks, if there is a big need for it.

 

The solution that I know works is to just install the 32-bit version of Cartes du Ciel. I have tested that and others have tested that, and it seems to work fine with the driver. 

 

To be clear, the issue only arises when you are connecting the 64-bit version of Cartes du Ciel directly to the PMC-Eight driver. If you are going to use more than one ASCOM client at the same time, such as Cartes du Ciel, and PHD2, the n you would need to use a driver hub, or server such as POTH which I recommend and comes with the ASCOM platform.  This is the easiest solution and gives you options going forward.

 

Jerry Hubbell

Director Electrical Engineering

Explore Scientific, LLC.