Topics

g-11 guiding


Brent Phillips
 

Ok I hope someone can lead me in the right direction because I have not been able to find an answer.  I am able to go 50-60 seconds unguided using the pole master, however when I go to use guiding I have several problems that come up.

1. When using an ASI120mm camera set to "on-camera" the stars get lost and the mount stops trying to calibrate (may be the computer will test on another computer tomorrow).

2. when set to "POTH ASCOM" I am told that the mount does not support pulse guiding.

3. when I set it to the PMC-Eight driver I am told ascom driver error access to COM6 denied.

when I switched to a different guide camera the Starlight Xpress Ultrastar mono I get the same messages but when I do "on Camera" the mount starts slewing all by itself the minute the st4 cable is connected.

I downloaded the new PMC driver and that did not help.  what am I missing? thanks for any help. 


hubbell_jerry@...
 

Hi Brent,

Sorry you are having a few issues with your system. I think I can get you going.

1. To help explain this problem and the solution I will get into a little background. The ST4 auto-guiding port on the PMC-Eight uses an analog multiplexer circuit. This design was chosen for various reasons, you can search CloudyNights to see my extended discussion on this. The design requirement was to match the original design input that SBIG and every other camera manufacturer used at the time, namely a switch or contact closure input. So when we do the factory calibration of the ST4 port, we use a simple 4 input momentary contact switch box like those used back in the day.

The issue arises now because todays cameras do not use relay contacts any long and use a transistor MOSFET switch. Different cameras use different transistors in terms of quality and output characteristics. The result is that different cameras when providing a pulse output for each cardinal direction provide different level of "contact closure" which do no match our factory calibration. The analog multiplexer circuit I designed uses a voltage to frequency converter so each cardinal direction is encoded as a specific frequency. The firmware converts this frequency to a direction and has a tolerance for input frequency of +/- 200. Some cameras inputs fall outside this range and therefore the PMC-Eight does not respond to those inputs. 

The fix here is for me to get with you on TeamViewer to run through the procedure of pulsing your camera and reading out your specific frequencies for each direction. I take that data and create a custom version of the firmware and then we load it up onto your box. This whole process can take as little as 10 minutes. It usually takes about 20-30 minutes because I explain everything I am doing. This will fix the system so that you can use the on-camera setting.  This fix requires you to have a Serial DB9 to USB adapter cable.

As an alternative, once you get the driver updated to the latest version, you can just use Pulse-Guiding and not worry about having your ST4 auto-guiding port calibrated and you wouldn't need the ST4 cable between the PMC-Eight and your camera.

2. You are still using the original version of the ASCOM driver. If you have installed the latest version of the driver posted here and you still get that message, then the .dll file did not get uninstalled and replaced with the new one. The ASCOM.ES_PMC8.Telescope.dll file is located in directory C:\Program Files (x86)/Common/ASCOM/Telescope. The latest release version is dated 02/19/2018 I believe. Typically, when you run the setup program for the latest driver install, it should remove this file and replace it with the new one. Sometimes that doesn't work so you have to manually run the uninstall on the driver first and then run the setup program for the new driver. That should place the new .dll file in the proper directory. You can uninstall the old driver by going to Settings/Apps and Features and look for the ASCOM driver in the list. Click on the driver and an option to uninstall should appear.

3. This error message occurs when you already have another client program connected to the driver. Sometimes it's not enough to disconnect the client from the program to release the port, you have to completely close that client to get it to release. Sometimes you have to make sure the client is not running by using the Task Manager.

If you want to use the ASCOM driver with multiple clients you need to use the ASCOM Platform POTH Telescope Dome Hub which acts as a server for multiple client programs.

4. If you want to be able to use multiple guide cameras, I would need run through the process discussed above in question 1 to provide a firmware file for each of your cameras. It is a simple matter to upload the firmware using the Serial DB9 to USB adapter cable. I have posted instructions on our website for doing this as Application Note AN001.  You may want to use Pulse-Guiding once you get your driver updated. This doesn't require the firmware update to use your cameras.

5. See the answer to question 2 above.

I hope this makes it clear, and provides you enough information to get you going. Please let me know if you have any other questions.

Thanks

Jerry Hubbell
Director Electrical Engineering
Explore Scientific, LLC.

 


Brent Phillips
 

thank you again Jerry as always you are very helpful.  I will try manually removing the driver and installing the new one to see if that fixes the issue.  I will keep you updated as I work through this.