No connection in Configuration Manager #EXOS2 #pmc-eight


Brett
 

Hi,
Just took delivery of my new mount.  I have already downloaded and installed the PMC Eight ASCOM Driver Setup 20210808 and the ASCOM Platform.  I have connected via wifi to the PMC-Eight.  The configuration manager confirms this connection at the bottom showing it as the current wifi network.  I also have the serial connection DB9 to USB (FTDI chipset) connected.  Current connection method it says "None".  I was able to get a "success" in the script on the advanced tab, so I think I got the firmware updated even though it says I'm not connected. I then tried opening the explore stars app (dell pc) with the wifi connected and the serial plugged in and the screen just stays on "please wait". Under preferences my lat/long is populated and mount changed to the exos.  The mount doesn't respond to any manual controls though.  What am I missing?  Sorry for the dumb questions. I appreciate the help.
--
Nikon D7200, Tamron 70-200 f2.8 and Tamron 150-600 f5.6 lenses 
Exos-2GT PMC-Eight
ZWO ASI120MM guide camera and mini guide scope
PHD2 and dell for guiding


S Branavan
 

Hi Brett,

I'm also new to the Exos2 pmc8.   When I have the usb-serial cable plugged into the pmc8 (latest firmware), the mount accepts wifi connections, but doesn't respond to commands via wifi.  If I unplug the serial cable from the pmc8 and power cycle it, it starts responding to wifi.

Someone with more experience here will probably have a solution for this.  But for now I'm unplugging the serial if I want to use wifi.

Branavan. 


On Wed, 19 Jan 2022, 19:13 Brett via groups.io, <bretthenry66=yahoo.com@groups.io> wrote:
Hi,
Just took delivery of my new mount.  I have already downloaded and installed the PMC Eight ASCOM Driver Setup 20210808 and the ASCOM Platform.  I have connected via wifi to the PMC-Eight.  The configuration manager confirms this connection at the bottom showing it as the current wifi network.  I also have the serial connection DB9 to USB (FTDI chipset) connected.  Current connection method it says "None".  I was able to get a "success" in the script on the advanced tab, so I think I got the firmware updated even though it says I'm not connected. I then tried opening the explore stars app (dell pc) with the wifi connected and the serial plugged in and the screen just stays on "please wait". Under preferences my lat/long is populated and mount changed to the exos.  The mount doesn't respond to any manual controls though.  What am I missing?  Sorry for the dumb questions. I appreciate the help.
--
Nikon D7200, Tamron 70-200 f2.8 and Tamron 150-600 f5.6 lenses 
Exos-2GT PMC-Eight
ZWO ASI120MM guide camera and mini guide scope
PHD2 and dell for guiding


Brett
 
Edited

That was a good suggestion!  I rushed to try it, but still stays on "please wait". Confirmed I am connected wifi to the PMC Eight. 

I found this thread: https://espmc-eight.groups.io/g/MAIN/topic/88492759#11193

Said my IP address and gateway need to be 192.168.47.1.    Typing cmd and then ipconfig, I have 169.254.146.77 and 255.255.0.0 .  I tried to manually configure it but I get an error that it can't save IP settings.  I left subnet mask and preferred DNS blank.  I'd attach a picture, but I don't see that as an option.

Laptop is a Dell with Windows 11 Home.  Database is correctly saved in pictures folder. 

--
Nikon D7200, Tamron 70-200 f2.8 and Tamron 150-600 f5.6 lenses 
Exos-2GT PMC-Eight
ZWO ASI120MM guide camera and mini guide scope
PHD2 and dell for guiding


Tyler Bowman - Explore Scientific Customer Service
 

where your using the UFCT, what is the wifi channel that its set to ? 

usually "please wait" is a wifi interference issue and changing the wifi channel will fix that. 
--

1458310636860_logo.png

 

Tyler Bowman - Customer Service

Office   +1(866) 252-3811 Ext: 516

Fax        +1(479) 717-2898


 

Hi Brett,

The IP address needs to be set to 192.168.47.11, not 192.168.47.1.  I set gateway to 192.168.47.1 and subnet to 255.255.255.0.  No entries for DNS.  These settings worked for me.  Give it a try.

Troy   


Brett
 

UFCT?

From wifi settings:
SSID: PMC-Eight-5D
Protocol: 802.11g
Security type: WPA2-Personal
Manufacturer: Intel Corporation
Description: Intel(R) Wi-Fi 6 AX201 160MHz
Driver version: 22.70.0.6
Network band: 2.4 GHz
Network channel: 1
Link speed (Receive/Transmit): 54/54 (Mbps)
Link-local IPv6 address: fe80::c135:b44f:deb9:924d%16
IPv6 DNS servers: fec0:0:0:ffff::1%1 (Unencrypted)
fec0:0:0:ffff::2%1 (Unencrypted)
fec0:0:0:ffff::3%1 (Unencrypted)
Physical address (MAC): 70-CD-0D-80-CA-32
 
--
Nikon D7200, Tamron 70-200 f2.8 and Tamron 150-600 f5.6 lenses 
Exos-2GT PMC-Eight
ZWO ASI120MM guide camera and mini guide scope
PHD2 and dell for guiding


Brett
 
Edited

Hi Troy. Thanks for catching the typo!  For some reason windows won't let me save those settings.  (I went into wifi for the PMC-8, then changed IP assignment from Automatic to manual and tried entering in those settings. 
--
Nikon D7200, Tamron 70-200 f2.8 and Tamron 150-600 f5.6 lenses 
Exos-2GT PMC-Eight
ZWO ASI120MM guide camera and mini guide scope
PHD2 and dell for guiding


Tyler Bowman - Explore Scientific Customer Service
 

Universal firmware configuation tool. 

Its the program we use to change motor currents, track on loss of comms, Northern Hemisphere, and run on boot, and change the wifi channel. 


--

1458310636860_logo.png

 

Tyler Bowman - Customer Service

Office   +1(866) 252-3811 Ext: 516

Fax        +1(479) 717-2898


 

Hi Brett,

I was able to change the settings using the old school Control Panel.  I didn't have any luck going through the new Windows 11 Wifi settings.

Troy


Brett
 

Using the UFCT, following the directions just to get current configuration, I get:  ESGi1152001000040040080900060000000!
COM3 and Exos2 are selected.  Serial connected and wifi. Wifi Channel says 0.

--
Nikon D7200, Tamron 70-200 f2.8 and Tamron 150-600 f5.6 lenses 
Exos-2GT PMC-Eight
ZWO ASI120MM guide camera and mini guide scope
PHD2 and dell for guiding


Wes Mcdonald
 

Brett:

Please change the wifi channel to 1, 6, or 11.  This is your problem, at least one of them if not the only one.
Wes.


--
Wes, Southport NC
EXos2-GT PMC-8, iExos 100, ESG11
ES ED 127+MoonLite Focuser, 10" LX200GPS+ MoonLite focuser+wedge, Astro-Tech 8" Newt, ETX-90, 60mm no-name guide scope ~ 260mm FL
Polemaster, Orion ST-80 and SAG, ZWO 290MM, D5300 astro modified, ASI071 cooled OSC, ASI MM290 guide camera
Nina, Bootcamped Mac Mini control computer, RDP to iMAC
110 amp hour lead acid deep discharge battery for field power
Electrical Engineer, Retired


Brett
 

Updated to channel 1.  Still stuck on "please wait"....
I tried closing out of explore stars, and turning the mount off/on. Reconnecting to the PMC8 wifi, with and without the serial plugged in.  All give me "please wait"
--
Nikon D7200
WO ZS81, Tamron 70-200 f2.8 and Tamron 150-600 f5.6 lenses 
Exos-2GT PMC-Eight
ZWO ASI120MM guide camera and ZWO mini guide scope
PHD2 and dell for guiding
Location: Denver, CO


Brett
 

Success!!!
I'll try to document the steps in case someone else is as clueless as me...  This is for Windows 11.

Control Panel>Network and Sharing Center
-You'll see next to Connections, "Wi-Fi (PMC-Eight-5D) in blue.  Click on that.
>Click on Properties
>Highlight "Internet Protocol Version 4 (TCP/IPv4)", then click on Properties
Here you can manually enter (Use the following IP address is selected):
IP address: 192.168.47.11
Subnet mask: 255.255.255.0
Default gateway: 192.168.47.1
I left "Use the following DNS server addresses" checked, but blank.
Hit Ok

The only downside is that it seems to set this for all my wifi connections.  So when I'm done using the mount, I need to go back in and switch this back to auto config in the same place I entered it manually.  It would be great if someone told me how to adjust this so I didn't have to enter it each time.  

Thanks!

--
Nikon D7200
WO ZS81, Tamron 70-200 f2.8 and Tamron 150-600 f5.6 lenses 
Exos-2GT PMC-Eight
ZWO ASI120MM guide camera and ZWO mini guide scope
PHD2 and dell for guiding
Location: Denver, CO


Wes Mcdonald
 

Brett:
Yes this fix you did is what I was about to tell you, once you confirmed the wifi channel number.

This is a thing that we had in the past, and it is a pain.  There is something about Windows that is making, for some tablets, laptops etc, DHCP on the exos 2 not work.  The "fix" is to just change things to static.  This is a pain because as you note, it applies to all connections, so your laptop is denied internet when not using the PMC8.

This is not something we can address with anything in the pmc8.  It used to affect everyone, then it went away, and now it seems it is back in Windows 11.

Glad you got it fixed.  Thanks for helping Folks!

Thanks for letting us know you got it going.  Now everyone can help the next guy that gets stuck with this thing.

Wes.


--
Wes, Southport NC
EXos2-GT PMC-8, iExos 100, ESG11
ES ED 127+MoonLite Focuser, 10" LX200GPS+ MoonLite focuser+wedge, Astro-Tech 8" Newt, ETX-90, 60mm no-name guide scope ~ 260mm FL
Polemaster, Orion ST-80 and SAG, ZWO 290MM, D5300 astro modified, ASI071 cooled OSC, ASI MM290 guide camera
Nina, Bootcamped Mac Mini control computer, RDP to iMAC
110 amp hour lead acid deep discharge battery for field power
Electrical Engineer, Retired


Brett
 

One other question-

I plan on using PHD2 to guide via my computer...  Can I use Explore Stars to get my telescope pointed to the correct object, then turn on PHD2 to take over?  Do I need to physically close Explore Stars on my computer or will PHD2 take over control of the mount regardless of whether it's open?

I had planned on testing it tonight, but the clouds are having other ideas.  Sigh..

Thank you 
--
Nikon D7200
WO ZS81, Tamron 70-200 f2.8 and Tamron 150-600 f5.6 lenses 
Exos-2GT PMC-Eight
ZWO ASI120MM guide camera and ZWO mini guide scope
PHD2 and dell for guiding
Location: Denver, CO


BobH
 

Brett, I played successfully with that same scenario - wireless tablet running ExploreStars to initially position, other ASCOM software interacting with the mount via the serial/USB link to my imaging laptop. No problems, and had a simultaneous connection (WiFi and Serial) running just fine. For example, either Stellarium on the laptop or ExploreStars on the tablet could slew to an object, the other would quickly pickup on the movement and accurately reflect it.

One caution - I was trial-running (indoors) a pass through the meridian, having initially positioned using EStars wirelessly, and fake-imaging via SharpCap over the serial port. My timing was set to run without a flip to about 20 minutes past meridian, but without any flip yet scripted. I walked away and found the mount flipped on my return. Wes figured it out for me - EStars had been driving 2-axis tracking on the object, and had caused the flip upon passing the meridian.

Cheers, Bob

--
Mounts: 1980's Celestron "EQ" Fork; Meade LXD55; Skywatcher Star Tracker; EXOS-II PMC-8
Optics: C-11; Meade AR5 Achromat Refractor; RedCat51; Various DSLR lenses
Cameras: ASI071 MC (DSO imaging); ASI290MM (guiding); ASI178MC (Planetary/Lunar imaging); Sony A700 DSLR
Computers: Win10Pro Laptop (ASCOM ecosystem, at-the-mount); RPi4b (INDI, on-the-scope); Win10Pro Workstation (networked remote control); Galaxy S5 Tablet
Misc: Pegasus power Pocket Adv (power mgmt, USB hub, dew/env); ZWO EAF; ZWO 1-Filter Drawer
Imaging SW: Stellarmate (low-power remote); SharpCap 4.0 Pro/Astap; PHD2; Stellarium; ASCOM 6.5.1
Processing: PixInsight; DSS; GIMP; F4W2HDU; AutoStakkert; RegiStax6
Wish-list: 5-inch class APO; Losmandy G-11; RASA-11?


Wes Mcdonald
 

You can do a goto with Explorestars.  When you get to the target be sure to put Explorestars intoT mode because you don’t want it pulsing your position.   


if you are using phd pulse guiding that will be fine to pulse guide While Explorestars is in T mode, although the pulse guide will work I think with Explorestars in P mode, i think.   The potential problem is Explorestars will be locked out when the pulse guide command comes in via the ascom driver and I am not sure if phd sets the rate back to tracking.   It must I would think.  But all in all if Explorestars ends up not locked out in this pulse guide case,  P mode might try to over ride the pulse guide over time .  Danged if I know.  Guide with Explorestars in T mode and avoid the uncertainty.


if you are using the st4 port for guiding with phd the mount will guide but Explorestars will not be locked out, ever.  So for sure the guiding will happen in P or T mode, but again over time P might override the guiding.  


all in all guide with Explorestars in T mode.

understand this is one of those creative off nominal cases for using dual mode where only pulse guiding is used and otherwise Explorestars is in control.  So results may vary.  


let’s us know ow how things work.  


wes
--
Wes, Southport NC
EXos2-GT PMC-8, iExos 100, ESG11
ES ED 127+MoonLite Focuser, 10" LX200GPS+ MoonLite focuser+wedge, Astro-Tech 8" Newt, ETX-90, 60mm no-name guide scope ~ 260mm FL
Polemaster, Orion ST-80 and SAG, ZWO 290MM, D5300 astro modified, ASI071 cooled OSC, ASI MM290 guide camera
Nina, Bootcamped Mac Mini control computer, RDP to iMAC
110 amp hour lead acid deep discharge battery for field power
Electrical Engineer, Retired


Brett
 

Finally a clear night, so I drove an hour east of Denver to get out of the light polluted sky.  Unfortunately I never got things to work right and finally gave up. A few lessons learned and a few head scratchers on what went wrong. 

1. Polar alignment. Should have made sure I understood this better since the diagram is different than my sky adventurer. I understand now that I have to rotate the polar scope so the line in the reticle crosses Kochab and then get Polaris in the tiny circle on the line.  I didn't rotate the line to Kochab, so my polar alignment was off.  Lesson learned.  Polar alignment diagram
2. I struggled to figure out the best way to determine if my stars were aligned, and then correct them during the star alignment process.  A bit cumbersome trying to take pictures on my DSLR then check the picture then figure out which way to move it to get the star centered then try again. I finally gave up and just called it good.  Do people use a red dot finder to speed this up? I'm assuming to calibrate a red dot with the scope during the day with a distant object is the way to go?
3. I slewed to Orion (wanted to pick an easy target to image), and even without a great polar alignment and just accepting the 2-star alignment, Orion showed up in my field of view.  With my setup, I have a 3 x 2 degree field of view (1.8 x 1.8 second per pixel, focal ratio 5.52, dawes limit 1.43 arc/secs if it matters).  The mount was in Tr mode. However I noticed Orion would quickly move out of the field of view like it wasn't tracking? Under OTA data the numbers were moving so I thought it was tracking?  At this point I tried to run PHD2 guiding, but it didn't work because the stars were moving out of frame. Was this all due to the polar alignment being slightly off? Tripod was level. 
4. Several times wifi dropped connection to Explore Stars. I only noticed it when trying to make fine adjustments to Orion in my field of view. I did have "track on loss of signal" enabled. Not sure what to do here, but I was having issues with it tracking even without the signal dropping.  Windows 11 laptop.  Confirming Explore Stars still only works with wifi even with the recent update?

Thank you
--
Nikon D7200
WO ZS81, Tamron 70-200 f2.8 and Tamron 150-600 f5.6 lenses 
Exos-2GT PMC-Eight
ZWO ASI120MM guide camera and ZWO mini guide scope
PHD2 and dell for guiding
Location: Denver, CO


Stephen Weiss
 

I recommend an app: PS Align Pro, it has a section (daytime polar alignment) that helps you get your rig very close to PA, then the program will show you exactly where to place polaris in your polar finder for the date, time and GPS location


On Sun, Jan 23, 2022 at 9:40 AM Brett via groups.io <bretthenry66=yahoo.com@groups.io> wrote:
Finally a clear night, so I drove an hour east of Denver to get out of the light polluted sky.  Unfortunately I never got things to work right and finally gave up. A few lessons learned and a few head scratchers on what went wrong. 

1. Polar alignment. Should have made sure I understood this better since the diagram is different than my sky adventurer. I understand now that I have to rotate the polar scope so the line in the reticle crosses Kochab and then get Polaris in the tiny circle on the line.  I didn't rotate the line to Kochab, so my polar alignment was off.  Lesson learned.  Polar alignment diagram
2. I struggled to figure out the best way to determine if my stars were aligned, and then correct them during the star alignment process.  A bit cumbersome trying to take pictures on my DSLR then check the picture then figure out which way to move it to get the star centered then try again. I finally gave up and just called it good.  Do people use a red dot finder to speed this up? I'm assuming to calibrate a red dot with the scope during the day with a distant object is the way to go?
3. I slewed to Orion (wanted to pick an easy target to image), and even without a great polar alignment and just accepting the 2-star alignment, Orion showed up in my field of view.  With my setup, I have a 3 x 2 degree field of view (1.8 x 1.8 second per pixel, focal ratio 5.52, dawes limit 1.43 arc/secs if it matters).  The mount was in Tr mode. However I noticed Orion would quickly move out of the field of view like it wasn't tracking? Under OTA data the numbers were moving so I thought it was tracking?  At this point I tried to run PHD2 guiding, but it didn't work because the stars were moving out of frame. Was this all due to the polar alignment being slightly off? Tripod was level. 
4. Several times wifi dropped connection to Explore Stars. I only noticed it when trying to make fine adjustments to Orion in my field of view. I did have "track on loss of signal" enabled. Not sure what to do here, but I was having issues with it tracking even without the signal dropping.  Windows 11 laptop.  Confirming Explore Stars still only works with wifi even with the recent update?

Thank you
--
Nikon D7200
WO ZS81, Tamron 70-200 f2.8 and Tamron 150-600 f5.6 lenses 
Exos-2GT PMC-Eight
ZWO ASI120MM guide camera and ZWO mini guide scope
PHD2 and dell for guiding
Location: Denver, CO


Brett
 

I use the free version of PS Align, but wasn't sure how the circle in PS Align worked with the single line in the PMC-8 reticle? My star adventurer had the same circle image, so it was pretty fool proof to figure it out.
--
Nikon D7200
WO ZS81, Tamron 70-200 f2.8 and Tamron 150-600 f5.6 lenses 
Exos-2GT PMC-Eight
ZWO ASI120MM guide camera and ZWO mini guide scope
PHD2 
Location: Denver, CO