Topics

PHD2 stopped talking to my mount #EXOS2 #OpenGOTO #ASCOM #pmc-eight


James Everson
 

Hello,
 
I have this odd issue that I can't seem to figure out. Here is a list of what I'm working with.
 
Mount: Explore Scientific EXOS II GT (connected over wifi not serial)
Scope: Explore Scientific AR102
Guide Scope: 190mm (focal length)
Guide Camera: ZWO ASI120MM Mini Monochrome
PC: Windows 10 Pro (all drivers and software are at the most recent versions)
Software: PHD2, ASCOM, and APT
 
When I set this up and ran it the very first time, it all worked as expected. The only difference between then and now, is that I the original setup was with my SpaceCat 51 scope. I changed the scope and ran through the wizard again to make a profile for the AR102. After that, I couldn't get PHD2 to complete a calibration. I did some digging and
in one of the articles I found, it suggested to use the manual controls in PHD2 with a high "sec" (5000ms) to see if it could move the mount and it didn't work. However, when I open the manual tool that comes with ASCOM, that moves the mount just fine as does the regular control software for the mount. I have tried uninstalling and re-installing PHD2. I have tried creating new profiles. I have run through the wizard several times. For some reason, PHD2 doesn't seem to want to "talk" via the ASCOM drivers even though it can see them and connect to the mount without errors. I am writing this from a different computer than the one I use for guiding so I cannot upload the logs from here. If you need them, I can get them. Just wondering if anyone has seen (and preferably fixed) this before?
 
Thanks


Jerry Hubbell - Explore Scientific VP Engineering
 

On Thu, Oct 15, 2020 at 09:57 AM, <jeverson.biz@...> wrote:
n one of the articles I found, it suggested to use the manual controls in PHD2 with a high "sec" (5000ms) to see if it could move the mount and it didn't work.

 Hi jeverson.biz

How are you connecting the mount to PHD2? Are you using the legacy ST4 cable? If so, I suggest you connect via the ASCOM driver instead of using "On camera" as it may be that your camera's ST4 port output does not match the factory calibration of the PMC-Eight ST4 port.

--
Jerry Hubbell
Vice President of Engineering

Explore Scientific, LLC.
jrh at explorescientific.com

www.explorescientificusa.com
1010 S. 48th Street
Springdale, AR 72762
1-866-252-3811

Author: Scientific Astrophotography: How Amateurs Can Generate and Use Professional Imaging Data
             Remote Observatories for Amateur Astronomers: Using High-Powered Telescopes From Home


Mark Slade Remote Observatory (MSRO) IAU MPC W54 Equipment
Wilderness, VA
Mounts
: ES PMC-Eight G11 + Telescope Drive Master (TDM)
Scopes: ES 165 FPL-53 ED APO CF, ES 102 FCD100 ED APO CF
Cameras:  QHY174M-GPS + FW, QHY163C
Misc: 3-inch 0.7x Focal Reducer Field Flattener, Filters: Luminance,
Red, V-band Photometric, Diffuser, 200 lpmm Spectral Grating

Software: MaxIm DL 6, Cartes du Ciel, Astrometrica, AstroImageJ, AutoStakkert!


James Everson
 

Jerry,

I have not been able to get either the ASCOM suite or PHD2 to connect via ST4. ASCOM just hangs or crashes when trying to connect via COM port over ST4. I will outline my connections.

Laptop to PMC-Eight: over Wifi
ASCOM suite: over WiFi
PHD2: connects via ASCOM driver over WiFi
Guide camera: connected via USB

ASCOM command from the ASCOM tools work fine over WiFi, ie: I can move the mount with the "manual" remote in the ASCOM suite.
PHD2 says it is connected to the mount and the guide camera without errors. I can see what the guide camera sees in PHD2. However, if I try to calibrate it fails, something about the star not moving enough. If I bring up the "manual" remote in PHD2, mount does not respond to commands.

All this said, the very first time I hooked everything up, it all ran like it is supposed to, but now it won't.

Thanks


Jerry Hubbell - Explore Scientific VP Engineering
 

Hi jeverson.biz,

Even though the ASCOM driver can be connected via WiFi, we always suggest that it is better and more reliable to connect via a USB serial adapter cable. The configuration is also better if you use the ASCOM POTH to connect to the PMC-Eight driver and then connect PHD2 and any other ASCOM client program to the POTH. The WiFi may be unreliable for you because of local WiFi traffic and/or the channel that the PMC-Eight WiFi connection is using.

In summary, the suggested configuration that provides the best reliability is to use

a) the PMC-Eight in Serial Mode with a Serial DB9 to USB FTDI chip adapter cable, 
b) the POTH to connect to the PMC-Eight driver,
c) your ASCOM Client programs connected to POTH, and
d) the ASCOM connection in PHD2 instead of the "On camera" connection for auto guiding.

--
Jerry Hubbell
Vice President of Engineering

Explore Scientific, LLC.
jrh at explorescientific.com

www.explorescientificusa.com
1010 S. 48th Street
Springdale, AR 72762
1-866-252-3811

Author: Scientific Astrophotography: How Amateurs Can Generate and Use Professional Imaging Data
             Remote Observatories for Amateur Astronomers: Using High-Powered Telescopes From Home


Mark Slade Remote Observatory (MSRO) IAU MPC W54 Equipment
Wilderness, VA
Mounts
: ES PMC-Eight G11 + Telescope Drive Master (TDM)
Scopes: ES 165 FPL-53 ED APO CF, ES 102 FCD100 ED APO CF
Cameras:  QHY174M-GPS + FW, QHY163C
Misc: 3-inch 0.7x Focal Reducer Field Flattener, Filters: Luminance,
Red, V-band Photometric, Diffuser, 200 lpmm Spectral Grating

Software: MaxIm DL 6, Cartes du Ciel, Astrometrica, AstroImageJ, AutoStakkert!


James Everson
 

Jerry,

OK. I have both a serial (DB9) cable and a serial (ST4) cable I can use. I have not been able to find directions on how to put the PMC8 into serial mode. Also, in serial mode, does that also disable WiFi?

Thanks


James Everson
 

Jerry,

OK. So I connected to my PMC8 module with the DB9 cable. Then I opened ES PMC8 Config Manager and enabled serial mode and disconnected from wifi.


Then I opened the ASCOM Device HUB (replaces POTH in ASCOM 6.5+). Went to setup. Selected the PMC8 ASCOM device. Went into settings and made sure that serial connection was selected.






I was able to move the mount from the HUB console. I then opened PHD2 and connected it to the ASCOM Device as you suggested.



I then brought up the manual guiding control in PHD2 but could not move the mount with the PHD2 controls.



What would you recommend from here?

Thank you


Andreas Volz
 

Think you need to check the "Tracking" checkbox.

<jeverson.biz@...> schrieb am Do., 15. Okt. 2020, 23:46:

Jerry,

OK. So I connected to my PMC8 module with the DB9 cable. Then I opened ES PMC8 Config Manager and enabled serial mode and disconnected from wifi.


Then I opened the ASCOM Device HUB (replaces POTH in ASCOM 6.5+). Went to setup. Selected the PMC8 ASCOM device. Went into settings and made sure that serial connection was selected.






I was able to move the mount from the HUB console. I then opened PHD2 and connected it to the ASCOM Device as you suggested.



I then brought up the manual guiding control in PHD2 but could not move the mount with the PHD2 controls.



What would you recommend from here?

Thank you


James Everson
 

Andreas

I know it’s not checked in the image, but I tried both with and without it checked. I can certainly try again, but it didn’t seem to change the outcome.

Thanks 



On Thu, Oct 15, 2020 at 5:56 PM Andreas Volz via groups.io <bassliner303=googlemail.com@groups.io> wrote:
Think you need to check the "Tracking" checkbox.

<jeverson.biz@...> schrieb am Do., 15. Okt. 2020, 23:46:
Jerry,

OK. So I connected to my PMC8 module with the DB9 cable. Then I opened ES PMC8 Config Manager and enabled serial mode and disconnected from wifi.


Then I opened the ASCOM Device HUB (replaces POTH in ASCOM 6.5+). Went to setup. Selected the PMC8 ASCOM device. Went into settings and made sure that serial connection was selected.






I was able to move the mount from the HUB console. I then opened PHD2 and connected it to the ASCOM Device as you suggested.



I then brought up the manual guiding control in PHD2 but could not move the mount with the PHD2 controls.



What would you recommend from here?

Thank you


--
Mounts: Explore Scientific EXOS II GT, iEXOS-100, Celestron AVX
Scope: Explore Scientific AR102, AR152, FirstLight 152mm Mak-Cassegrain, SpaceCat 51
Guide Scope: Astromania 50mm Guidescope (190mm focal length)
Guide Camera: ZWO ASI120MM Mini Monochrome
Camera: Canon RP (IR modification)
Software: PHD2, ASCOM, and APT


Andreas Volz
 

Hmm, okay. 

Does the Device Hub at least show that there is some client connected to it? Should show up in the upper right corner. 

Regards,
Andreas 

James Everson <jeverson.biz@...> schrieb am Fr., 16. Okt. 2020, 01:03:

Andreas

I know it’s not checked in the image, but I tried both with and without it checked. I can certainly try again, but it didn’t seem to change the outcome.

Thanks 



On Thu, Oct 15, 2020 at 5:56 PM Andreas Volz via groups.io <bassliner303=googlemail.com@groups.io> wrote:
Think you need to check the "Tracking" checkbox.

<jeverson.biz@...> schrieb am Do., 15. Okt. 2020, 23:46:
Jerry,

OK. So I connected to my PMC8 module with the DB9 cable. Then I opened ES PMC8 Config Manager and enabled serial mode and disconnected from wifi.


Then I opened the ASCOM Device HUB (replaces POTH in ASCOM 6.5+). Went to setup. Selected the PMC8 ASCOM device. Went into settings and made sure that serial connection was selected.






I was able to move the mount from the HUB console. I then opened PHD2 and connected it to the ASCOM Device as you suggested.



I then brought up the manual guiding control in PHD2 but could not move the mount with the PHD2 controls.



What would you recommend from here?

Thank you


--
Mounts: Explore Scientific EXOS II GT, iEXOS-100, Celestron AVX
Scope: Explore Scientific AR102, AR152, FirstLight 152mm Mak-Cassegrain, SpaceCat 51
Guide Scope: Astromania 50mm Guidescope (190mm focal length)
Guide Camera: ZWO ASI120MM Mini Monochrome
Camera: Canon RP (IR modification)
Software: PHD2, ASCOM, and APT


 

Could it still be in Park mode?

Chuck Lewis

 

From: MAIN@ESPMC-Eight.groups.io <MAIN@ESPMC-Eight.groups.io> On Behalf Of Andreas Volz via groups.io
Sent: Thursday, October 15, 2020 6:12 PM
To: MAIN@espmc-eight.groups.io
Subject: Re: [ESPMC-Eight] PHD2 stopped talking to my mount #EXOS2 #OpenGOTO #pmc-eight #ASCOM

 

Hmm, okay. 

 

Does the Device Hub at least show that there is some client connected to it? Should show up in the upper right corner. 

 

Regards,

Andreas 

 

James Everson <jeverson.biz@...> schrieb am Fr., 16. Okt. 2020, 01:03:

Andreas

 

I know it’s not checked in the image, but I tried both with and without it checked. I can certainly try again, but it didn’t seem to change the outcome.

 

Thanks 

 

 

 

On Thu, Oct 15, 2020 at 5:56 PM Andreas Volz via groups.io <bassliner303=googlemail.com@groups.io> wrote:

Think you need to check the "Tracking" checkbox.

<jeverson.biz@...> schrieb am Do., 15. Okt. 2020, 23:46:

Jerry,

OK. So I connected to my PMC8 module with the DB9 cable. Then I opened ES PMC8 Config Manager and enabled serial mode and disconnected from wifi.


Then I opened the ASCOM Device HUB (replaces POTH in ASCOM 6.5+). Went to setup. Selected the PMC8 ASCOM device. Went into settings and made sure that serial connection was selected.






I was able to move the mount from the HUB console. I then opened PHD2 and connected it to the ASCOM Device as you suggested.



I then brought up the manual guiding control in PHD2 but could not move the mount with the PHD2 controls.



What would you recommend from here?

Thank you


--

Mounts: Explore Scientific EXOS II GT, iEXOS-100, Celestron AVX

Scope: Explore Scientific AR102, AR152, FirstLight 152mm Mak-Cassegrain, SpaceCat 51

Guide Scope: Astromania 50mm Guidescope (190mm focal length)

Guide Camera: ZWO ASI120MM Mini Monochrome
Camera: Canon RP (IR modification)

Software: PHD2, ASCOM, and APT


--
Scope: Explore Scientific AR-102, Astro-Tech AD72ED, Nikon kit lenses
Mounts: Exos2GT-PMC8, Homebrew barndoor tracker
Camera: Nikon D7000, QHY5III-462C
S/W:  Backyard Nikon, DeepSkyStacker, Stellarium, CdC, PHD2, Sharpcap Pro, Gimp, RawTherapee


Doug Walker
 

FWIW,

I had nothing but problems with guiding using the new Device Hub. Switched to POTH and haven't had an issue since. If you've installed the latest Ascom then you have to run the installer again and specifically select it from the Out of Date Hubs" section.



--
Explore Scientific iEXOS-100
Canon T1i (no mod)
Canon 18-55mm zoom lens
Canon 75-300mm zoom lens
Astromania 60mm guidescope
ZWO ASI 120MC-S
Lenovo m93 / Win10Pro
NINA, DSS, SiriL, GIMP, Phd2


James Everson
 

Andreas 

Not sure what you mean. What client are you referring to?

Thanks



On Thu, Oct 15, 2020 at 7:12 PM Andreas Volz via groups.io <bassliner303=googlemail.com@groups.io> wrote:
Hmm, okay. 

Does the Device Hub at least show that there is some client connected to it? Should show up in the upper right corner. 

Regards,
Andreas 

James Everson <jeverson.biz@...> schrieb am Fr., 16. Okt. 2020, 01:03:
Andreas

I know it’s not checked in the image, but I tried both with and without it checked. I can certainly try again, but it didn’t seem to change the outcome.

Thanks 



On Thu, Oct 15, 2020 at 5:56 PM Andreas Volz via groups.io <bassliner303=googlemail.com@groups.io> wrote:
Think you need to check the "Tracking" checkbox.

<jeverson.biz@...> schrieb am Do., 15. Okt. 2020, 23:46:
Jerry,

OK. So I connected to my PMC8 module with the DB9 cable. Then I opened ES PMC8 Config Manager and enabled serial mode and disconnected from wifi.


Then I opened the ASCOM Device HUB (replaces POTH in ASCOM 6.5+). Went to setup. Selected the PMC8 ASCOM device. Went into settings and made sure that serial connection was selected.






I was able to move the mount from the HUB console. I then opened PHD2 and connected it to the ASCOM Device as you suggested.



I then brought up the manual guiding control in PHD2 but could not move the mount with the PHD2 controls.



What would you recommend from here?

Thank you


--
Mounts: Explore Scientific EXOS II GT, iEXOS-100, Celestron AVX
Scope: Explore Scientific AR102, AR152, FirstLight 152mm Mak-Cassegrain, SpaceCat 51
Guide Scope: Astromania 50mm Guidescope (190mm focal length)
Guide Camera: ZWO ASI120MM Mini Monochrome
Camera: Canon RP (IR modification)
Software: PHD2, ASCOM, and APT


--
Mounts: Explore Scientific EXOS II GT, iEXOS-100, Celestron AVX
Scope: Explore Scientific AR102, AR152, FirstLight 152mm Mak-Cassegrain, SpaceCat 51
Guide Scope: Astromania 50mm Guidescope (190mm focal length)
Guide Camera: ZWO ASI120MM Mini Monochrome
Camera: Canon RP (IR modification)
Software: PHD2, ASCOM, and APT


James Everson
 

Doug,

I reran the ASCOM installer and installed the all the legacy components.





I was able to connect POTH over serial without issue. I then went back into PHD2 and pointed it at the POTH ASCOM device. Still no dice. The manual buttons do not move the mount. I tried setting POTH to parked/unparked and also toggled the tracking box.



Is there anything else to look at in POTH? Any other ideas?

Thanks


--
Mounts: Explore Scientific EXOS II GT, iEXOS-100, Celestron AVX
Scope: Explore Scientific AR102, AR152, FirstLight 152mm Mak-Cassegrain, SpaceCat 51
Guide Scope: Astromania 50mm Guidescope (190mm focal length)
Guide Camera: ZWO ASI120MM Mini Monochrome
Camera: Canon RP (IR modification)
Software: PHD2, ASCOM, and APT


Doug Walker
 

did the motion controls in POTH work?

On 10/15/2020 9:59 PM, James Everson wrote:
Doug,

I reran the ASCOM installer and installed the all the legacy components.





I was able to connect POTH over serial without issue. I then went back into PHD2 and pointed it at the POTH ASCOM device. Still no dice. The manual buttons do not move the mount. I tried setting POTH to parked/unparked and also toggled the tracking box.



Is there anything else to look at in POTH? Any other ideas?

Thanks


--
Mounts: Explore Scientific EXOS II GT, iEXOS-100, Celestron AVX
Scope: Explore Scientific AR102, AR152, FirstLight 152mm Mak-Cassegrain, SpaceCat 51
Guide Scope: Astromania 50mm Guidescope (190mm focal length)
Guide Camera: ZWO ASI120MM Mini Monochrome
Camera: Canon RP (IR modification)
Software: PHD2, ASCOM, and APT
--
Explore Scientific iEXOS-100
Canon T1i (no mod)
Canon 18-55mm zoom lens
Canon 75-300mm zoom lens
Astromania 60mm guidescope
ZWO ASI 120MC-S
Lenovo m93 / Win10Pro
NINA, DSS, SiriL, GIMP, Phd2


James Everson
 

Doug,

I couldn't find them. That said, when I clicked on the home button it did return the mount to the home position. So no reason to think the controls wouldn't work. Are the controls under the "telescope simulator"?

Thanks


--
Mounts: Explore Scientific EXOS II GT, iEXOS-100, Celestron AVX
Scope: Explore Scientific AR102, AR152, FirstLight 152mm Mak-Cassegrain, SpaceCat 51
Guide Scope: Astromania 50mm Guidescope (190mm focal length)
Guide Camera: ZWO ASI120MM Mini Monochrome
Camera: Canon RP (IR modification)
Software: PHD2, ASCOM, and APT


Doug Walker
 

On the setup screen, check the Motion Controls checkbox.

On 10/15/2020 10:09 PM, James Everson wrote:
Doug,

I couldn't find them. That said, when I clicked on the home button it did return the mount to the home position. So no reason to think the controls wouldn't work. Are the controls under the "telescope simulator"?

Thanks


--
Mounts: Explore Scientific EXOS II GT, iEXOS-100, Celestron AVX
Scope: Explore Scientific AR102, AR152, FirstLight 152mm Mak-Cassegrain, SpaceCat 51
Guide Scope: Astromania 50mm Guidescope (190mm focal length)
Guide Camera: ZWO ASI120MM Mini Monochrome
Camera: Canon RP (IR modification)
Software: PHD2, ASCOM, and APT
--
Explore Scientific iEXOS-100
Canon T1i (no mod)
Canon 18-55mm zoom lens
Canon 75-300mm zoom lens
Astromania 60mm guidescope
ZWO ASI 120MC-S
Lenovo m93 / Win10Pro
NINA, DSS, SiriL, GIMP, Phd2


Tyler Bowman - Explore Scientific Customer Service
 

Im curious on why your using the Device HUB instead of POTH.

 

1458310636860_logo.png

 

Tyler Bowman - Customer Service

Office   +1(866) 252-3811 Ext: 516

Fax        +1(479) 717-2898

 

EXPLORE SCIENTIFIC, LLC

1010 South 48th Street

Springdale, AR 72762 USA

 

Brands: Explore Scientific | Bresser | Explore One 
Official Licensee: National Geographic | Discovery

 

Publications:  Sky's Up Magazine

 

Affiliations: UNESCO Space Education Program | AstronomyOutreach network

 

 

From: MAIN@ESPMC-Eight.groups.io <MAIN@ESPMC-Eight.groups.io> On Behalf Of jeverson.biz via groups.io
Sent: Thursday, October 15, 2020 4:46 PM
To: MAIN@ESPMC-Eight.groups.io
Subject: Re: [ESPMC-Eight] PHD2 stopped talking to my mount #EXOS2 #OpenGOTO #pmc-eight #ASCOM

 

Jerry,

OK. So I connected to my PMC8 module with the DB9 cable. Then I opened ES PMC8 Config Manager and enabled serial mode and disconnected from wifi.


Then I opened the ASCOM Device HUB (replaces POTH in ASCOM 6.5+). Went to setup. Selected the PMC8 ASCOM device. Went into settings and made sure that serial connection was selected.






I was able to move the mount from the HUB console. I then opened PHD2 and connected it to the ASCOM Device as you suggested.



I then brought up the manual guiding control in PHD2 but could not move the mount with the PHD2 controls.



What would you recommend from here?

Thank you


--

1458310636860_logo.png

 

Tyler Bowman - Customer Service

Office   +1(866) 252-3811 Ext: 516

Fax        +1(479) 717-2898


James Everson
 

Because this is my first time setting this up and I didn't know there was a difference. That said, I have tested this with both and get the same result, so is the "why" important?

Thanks

--
Mounts: Explore Scientific EXOS II GT, iEXOS-100, Celestron AVX
Scope: Explore Scientific AR102, AR152, FirstLight 152mm Mak-Cassegrain, SpaceCat 51
Guide Scope: Astromania 50mm Guidescope (190mm focal length)
Guide Camera: ZWO ASI120MM Mini Monochrome
Camera: Canon RP (IR modification)
Software: PHD2, ASCOM, and APT


Jennifer Shelly
 

The third screen shot in post 8515 shows the mount is connected, but the camera is not connected.  I am not sure if it makes a difference or not, but have you tried connecting the camera and the mount at the same time and the tried moving the mount in PHD2?  

What is your procedure for connecting the mount?  Are you first connecting to POTH then connecting to POTH In PHD2?

Have you tried running ALL of your astronomy programs in Admin mode? If not, it may be worth a shot.

Which ASCOM driver are you using for the PMC-8?  Is it the Any-CPU version?


Sincerely,

Jennifer Shelly
AstroPorch, VA

Mounts
: ES PMC-8 G-11, ES PMC-8 EXOS-2
Scopes: ES ED127 FCD-100, ES Levy Comet Hunter, ES N208CF, QHY Mini Guide Scope, Solomark F60 Guide Scope
Cameras: QHY600M, QHY128C, QHY168C
Misc: MoonLite CFL 2.5 / High Res Stepper / V2 Mini Controller, Baader SteelTrack NT / SteelDrive II, Baader UFC, Optolong 2" L-Pro / L-eNhance, QHY CFW3-L, Baader 2” LRGBSHO CCD
Imaging Software:  NINA, APT, SharpCap Pro
Processing Software: PixInsight, Lightroom, Premiere Elements


Tyler Bowman - Explore Scientific Customer Service
 

Ive had better luck with the POTH instead of the DEVICE HUB but let me know

 

1458310636860_logo.png

 

Tyler Bowman - Customer Service

Office   +1(866) 252-3811 Ext: 516

Fax        +1(479) 717-2898

 

EXPLORE SCIENTIFIC, LLC

1010 South 48th Street

Springdale, AR 72762 USA

 

Brands: Explore Scientific | Bresser | Explore One 
Official Licensee: National Geographic | Discovery

 

Publications:  Sky's Up Magazine

 

Affiliations: UNESCO Space Education Program | AstronomyOutreach network

 

 

From: MAIN@ESPMC-Eight.groups.io <MAIN@ESPMC-Eight.groups.io> On Behalf Of James Everson via groups.io
Sent: Friday, October 16, 2020 8:05 AM
To: MAIN@ESPMC-Eight.groups.io
Subject: Re: [ESPMC-Eight] PHD2 stopped talking to my mount #EXOS2 #OpenGOTO #pmc-eight #ASCOM

 

Because this is my first time setting this up and I didn't know there was a difference. That said, I have tested this with both and get the same result, so is the "why" important?

Thanks

--

Mounts: Explore Scientific EXOS II GT, iEXOS-100, Celestron AVX

Scope: Explore Scientific AR102, AR152, FirstLight 152mm Mak-Cassegrain, SpaceCat 51

Guide Scope: Astromania 50mm Guidescope (190mm focal length)

Guide Camera: ZWO ASI120MM Mini Monochrome
Camera: Canon RP (IR modification)

Software: PHD2, ASCOM, and APT


--

1458310636860_logo.png

 

Tyler Bowman - Customer Service

Office   +1(866) 252-3811 Ext: 516

Fax        +1(479) 717-2898