Wifi / PMC-8 connection/comms issue. #EXOS2 #ConfigManager #pmc-eight #UniversalFirmware


Al Knox
 

Hi, 
I'm trying to find a solution to a comms problem with my EXOS2 PMC-Eight unit.
I'm not able to switch over to Wifi control/comms using any of the available Config Manager apps and command routines (EXS!) using the serial port connection.

I've got the latest Eprom installed ok, using a serial cable connection comms to and from the connected Windows 10 laptop works (see screen shots below).
I am able to get the Wifi board into an 'on' state using the 'high' state 'jumper' solution and the SSID is offering the ES default IP address set for the device with the 'ad-hoc' router.
Wifi connection via both an IOS device and the Windows 10 laptop works, but there seems to be no control comms available via tcp (PuTTY). Removing the jumper (power on), the wifi board holds connection but none of the command line calls to switch between serial and wifi (EXS!) return a result (which in theory shouldn't be necessary with the latest Eprom flash(?)).
When I power off and on the PMC-8 with the jumper no longer in place the board just boots back to the serial line only state. With the jumper in place the ES default 'ad-hoc' network comes up - but no comms through the main unit to control the mount motors via Explore Stars IOS. The wifi channel change (ST4 port dongle) seems to work when one allows the boot process to cycle it - but if set manually with the new Configuration Manager it seems to throw a programme error when polling back the config set up - and in Explore Stars the DEC shows 0' 00' 0" instead of 90' 00' 0".

Hopefully anyone that is closer to the coding will be able to suggest a way to either run a diagnostic that can point to why and what needs to be done to get the unit back to a functioning control state?

Here are my screen images taken in sequential order:-

1) PuTTY attempt to communicate via tcp to the SSID (note ES default IPs showing up ok) 



Windows 10 laptop connected ok to SSID and acquired correct ES default IPs.


Windows 10 Wifi connected fine.


Running the UFCT in the above state shows a mismatch on the wifi network channel '10' when it should have been '1'


... doing a reboot to see splash screen diagnostics ... network channel reads '10' still.


After a full power off and removal of jumper using Serial term get this read out.


Attempt to use the command line switch (ESX!) to instantiate the wifi board without jumper in place.


Check setup again with UFCT (network channel seems to have changed correctly after 2 goes with the dongle - starting from '1' as read from the laptop settings page (see above) and incrementing up to '3'.


And again displaying the splash screen


The only tell-tail here seems to be the 'grey'd' out ESP WiFi line.

Any thoughts greatly appreciated!
Thanks! 

-
-
--
Al Knox, London UK.

Mounts
: ES PMC-8 EXOS2, Simple surveyor's tripod mounted SkyWatcher Star Adventurer (V1)
TelescopesTS-Optics 61EDPH, TS-Optics Photoline 80mm f/6 FPL53 Triplet APO, TS-Optics Classical Cassegrain 8" F12 203/2436mm
Cameras:  Nikon D7200, QHYCCD QHY10 Color (CCD), QHYCCD QHY5III462C (CMOS)
Software: Mostly Mac OSX based,  INDIGO suit, ASCOM, Sharpcap, FireCapture, Stark Labs Nebulosity4, SiriL, Affinity Photo, StarTools, Sequator etc.


Wes Mcdonald
 

Al

Ok.  You are fine.  Believe it or not.  Leave the internals of the pmc8 alone, do not go jumpering stuff. 

The splash screen shows all is well.  Your system is communicating well over serial.  As the splash screen shows the comms mode is udp....but in fact the rn131 does not care. 

The grayed out esp note means you don’t have an esp module.  Which is correct.  You have the rn131

The unit with the new firmware communicates all the time on either WiFi or serial, no need to switch.

Explorestars will talk to the rn131 via udp.  Frankly I can’t remember if you need to tell the firmware it’s udp or not I don’t think so with the 131.

So let’s see what is going on since nothing seems amiss.


1.  Why did the comm manager not get a response from the esgp command?  Can’t tell for sure but you have to go to the comms tab and make sure comm port is selected

2. WiFi should connect.  Use Explorestars and see

3.  The command that switched between serial and WiFi is gone.  That’s why you get no response to it

See if any of this helps you understand the behavior and if you can get stuff to work.  It sure looks like it is fine

Wes







--
Wes, Southport NC
EXos2-GT PMC-8, iExos 100
ES ED 127, 10" LX200GPS+wedge, Astro-Tech 8" Newt, ETX-90, 60mm no-name guide scope ~ 260mm FL
Polemaster, Orion ST-80 and SAG, ZWO 290MM, D5300 astro modified
Nina, Bootcamped Mac Mini control computer, RDP to iMAC
110 amp hour lead acid deep discharge battery for field power
Electrical Engineer, Retired


Al Knox
 

Hi Wes,

Thanks for taking the time to go through my stack of 'I did this, I did that' notes! Your insights are greatly appreciated.
Based on my now better understanding, I think I have reduced the problem down to one thing (from my perspective) ...
The WiFi board is not actually going into transmit mode - even though it now should do with the new duel open port setup with the latest eeprom load package.
Basically its the ESX! command isn't having any effect as you say because its no longer executed in the command stack. But the RN-131 isn't going into broadcast mode (except when jumpered at boot up, on power up). From one of my previous screen images (Windows WiFi settings page) you can see that there is DNS entry of 192.168.1.1 not just the ES 'ad-hoc' setting of 192.168.47.1. This was my old home network router's primary NAT IP address. But I'm thinking how could that still be in the settings file if the unit was jumper set back to the ES settings file - or indeed the later was part of the firmware update(?). I can't find a way of polling the IP settings on the RN-131 via a serial connection, as presumably its only accessible via the RN-131 wireless port directly using TCP/UDP protocol(?).

Here's the current splash screen - and you can see I've switch to TCP from UDP - showing that the command entry line is working with the UFCT app.
 

Here too are a couple of videos of the PMC-Eight LED panel (see attached):-
First the reboot phase, then one of the 'resting' phase. As you can see the yellow wifi LED flashes at reboot but then turns off and stays off while and after ere serial line test is done.

I'm wondering if this is a redeamable situation from here, or if I'm going to have to try the 1hz x 5 reset operation back to the WiFly default and then PuTTY in, to rebuild the ES settings file?
 
Regards

--
--
Al Knox, London UK.

Mounts
: ES PMC-8 EXOS2, Simple surveyor's tripod mounted SkyWatcher Star Adventurer (V1)
TelescopesTS-Optics 61EDPH, TS-Optics Photoline 80mm f/6 FPL53 Triplet APO, TS-Optics Classical Cassegrain 8" F12 203/2436mm
Cameras:  Nikon D7200, QHYCCD QHY10 Color (CCD), QHYCCD QHY5III462C (CMOS)
Software: Mostly Mac OSX based,  INDIGO suit, ASCOM, Sharpcap, FireCapture, Stark Labs Nebulosity4, SiriL, Affinity Photo, StarTools, Sequator etc.


Wes Mcdonald
 

Al

There is one setting on the run 131 setup that sets it for its external antenna.  Suggest you put your PC immediately next to the pmc8 and see can it connect.  If the external antenna is not selected the output signal can be very low.

Note for the pc to have the ip address of 192.168.47.11 it got that from the rn131.  That means the rn is able to transmit.   

I take it that if you try to connect via putty it will not?  Did you input the $$$ to get the run into cmd mode?

You didn’t update your firmware in the end did you?  When I did mine the cmd program was not included and that ended my ability to use putty.

Your rn can be reprogrammed via its internal serial port but ES will have to do it for you if all else fails.

Wes


--
Wes, Southport NC
EXos2-GT PMC-8, iExos 100
ES ED 127, 10" LX200GPS+wedge, Astro-Tech 8" Newt, ETX-90, 60mm no-name guide scope ~ 260mm FL
Polemaster, Orion ST-80 and SAG, ZWO 290MM, D5300 astro modified
Nina, Bootcamped Mac Mini control computer, RDP to iMAC
110 amp hour lead acid deep discharge battery for field power
Electrical Engineer, Retired


Al Knox
 

Hi Wes,

Thanks for your further thoughts. I can say for certain the RN-131 is connectable when it is broadcasting - the yellow LED flashing on and off confirms that - but that is only possible when I have the jumper cable in place at PMC-Eight power up. Also with the latest eeprom build I am getting both serial and RN-131 connection and IP assignments. But apart from the diagnostics (as seen in previous image posts) I'm not getting command line access to the RN-131. The wifi aerial is evidently working as I can get connection when the wifi board is obviously in a broadcasting state (jumper line i place). When there's no jumper in place and I reboot either warm-reboot through the UFCT app or cold-reboot power off/on cycle, the LED light stays off after the initial boot-cycle check and there's no PMC network available. I have even tried going back to eeprom build 15a to see if I could get PuTTY access again - but that didn't work either ... which might be because the previous onboard settings files are not deleted with a eeprom upload - as opposed to the other PMC-Eight Configuration Manager page option that has a tick box to delete 'old files'. The later only has a default load package link available which is the current eeprom distribution .zip file. Despite trying to get a work around, there seems to be a persitant fail over that I think stems from having mismatched settings between the PMC-Eight mother board and the RN-131, that stopping comms going from the PMC-Eight to the RN-131 and visa versa.
I'd like to get a clean reset with the current build - but it seems that's not possible now with PuTTY access removed. Its somewhat frustrating as it was all working fine before and I had no problems until the mode of connection was lost (my home router being replaced before I could reset the PMC to ad-hoc settings). There must be some way to get a comprehensive diagnostic to get a proper read on what all the settings are both PMC-Eight and the RN-131 daughter board?

Cheers! 

--
--
Al Knox, London UK.

Mounts
: ES PMC-8 EXOS2, Simple surveyor's tripod mounted SkyWatcher Star Adventurer (V1)
TelescopesTS-Optics 61EDPH, TS-Optics Photoline 80mm f/6 FPL53 Triplet APO, TS-Optics Classical Cassegrain 8" F12 203/2436mm
Cameras:  Nikon D7200, QHYCCD QHY10 Color (CCD), QHYCCD QHY5III462C (CMOS)
Software: Mostly Mac OSX based,  INDIGO suit, ASCOM, Sharpcap, FireCapture, Stark Labs Nebulosity4, SiriL, Affinity Photo, StarTools, Sequator etc.


Wes Mcdonald
 

Al

Some of your suppositions about things are not right, but your bottom line conclusion that the rn131 settings are altered and thus not working for you are correct.  The main thing is that the pmc8 communicates over a serial port to the rn131 and there is no setting that can stop that.

Btw did you ever try to load new rn131 firmware?  Hopefully not.  It is a problem prone process (microchip problems) and left my unit in a workable but altered state where I cannot anymore use putty.  Fortunately it has the necessary settings.

What has happened is that during your resetting of the 131 some of the settings that are required for all of this to work were altered. You are correct that these need to be restored.

It has been a long while since I worked with my 131 with resets etc, so the details of it all escape me.  But I believe I remember that when you boot with the io pin jumpered the thing comes up in a default configuration.  One of the hallmarks of this is that the network is open, which one of your earlier images shows is the case (showing windows connection status).  This condition is not gonna work with the pmc8 but it seems to me I remember that in that state one could communicate to the 131 directly via putty.  Once there you can change all the settings, saving them as you go either individually or in groups, with a final save and reboot .  The new settings go into effect upon reboot with the jumper removed.  If you reboot with the jumper in the boot happens with the default (microchip) 131 defaults again.   

I remember that things like the ip address are persistent even with defaults boot, and I think even if you do a reset command.  But don’t quote me on that.

As I said, if you send the pmc8 back the 131 can be reprogrammed.   It is not broken.  Just needs access via methods not available to you.

Suggest you reach out to Tyler directly and see can you set up a return.  They can get you up and running in no time.  It’s no use banging your head against this particular wall.

Wes

--
Wes, Southport NC
EXos2-GT PMC-8, iExos 100
ES ED 127, 10" LX200GPS+wedge, Astro-Tech 8" Newt, ETX-90, 60mm no-name guide scope ~ 260mm FL
Polemaster, Orion ST-80 and SAG, ZWO 290MM, D5300 astro modified
Nina, Bootcamped Mac Mini control computer, RDP to iMAC
110 amp hour lead acid deep discharge battery for field power
Electrical Engineer, Retired


Al Knox
 

Thanks Wes again for your thoughts on this. I've raised a support ticket and they will be getting back to me in a few days with a suggested solution.

Cheers!
--
--
Al Knox, London UK.

Mounts
: ES PMC-8 EXOS2, Simple surveyor's tripod mounted SkyWatcher Star Adventurer (V1)
TelescopesTS-Optics 61EDPH, TS-Optics Photoline 80mm f/6 FPL53 Triplet APO, TS-Optics Classical Cassegrain 8" F12 203/2436mm
Cameras:  Nikon D7200, QHYCCD QHY10 Color (CCD), QHYCCD QHY5III462C (CMOS)
Software: Mostly Mac OSX based,  INDIGO suit, ASCOM, Sharpcap, FireCapture, Stark Labs Nebulosity4, SiriL, Affinity Photo, StarTools, Sequator etc.